8

As of recent, every time I open chrome, this window pops up: This opens along with chrome The default application for protocols window annoyingly pops up. How do I fix this?

Edit: I've tried deleting the cache, but this window still pops up. I've also tried setting the default browser to another browser nd setting it back to Chrome. This issue still persists. What do I do?

3
  • 1
    In Settings / Apps / Default apps, is Chrome the default Web browser? – harrymc May 9 '17 at 14:21
  • 1
    @harrymc: Yes, as of now. This happens regardless of whether it is or not. – Nick May 9 '17 at 16:02
  • 1
    In same screen, use the "Choose default apps by protocol" button and check if Chrome is set for FTP, HTTP & HTTPS. Repeat this for "Choose default apps by file type" (very slow to load) for .htm & .html. – harrymc May 9 '17 at 17:46
5
+25

I would try launching chrome without any plugins or extensions. This is from an old link, but I tested quick and it works. You need to close Chrome completely first.

--disable-extensions Disable extensions.

--disable-plugins Prevent plugins from running

http://peter.sh/experiments/chromium-command-line-switches/

4

You should check if in PC Settings / Apps / Default apps :

  1. Chrome should be the default Web browser
  2. Click on "Choose default apps by protocol" and check if Chrome is set as handler for the protocols of FTP, HTTP, HTTPS.
  3. Click on "Choose default apps by file type" (very slow to load) check if Chrome is set as handler for .htm and .html
3

I have confronted this issue one time before but after I set default value for those settings, it never shows up again. I would recommend trying the same thing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.