5

What happens: Works fine with 16GB. With 32GB, powers-on but screen is blank. Tried second laptop (also ivybridge) and found same.

Laptop: W110ER with i7 3820QM Ivybridge cpu and Win7 server 2008 R2 standard SP1. http://www.notebookcheck.net/Review-Clevo-W110ER-Barebone-Subnotebook.75104.0.html see current cpuz http://valid.x86.fr/0fbz5t

Memory: 32GB DDR3 1867 MHz SO-DIMM Memory Kit (2 x 16GB)

Background: The W110ER (for reasons I don't know) supports 16GB (2 x 8GB modules) of 1600 DDR3. In the past I have learned that often the max ram is simply what the mfg thought was the most ram anyone would put in the laptop or was available at the time of product launch (I had an HP with a spec max 2GB of RAM and later found that 8GB worked fine, it was an x32 OEM). So, I ignore the RAM specs. Right now, I am running 16GB of 2133 DDR3 RAM underclocked slightly to 2128 (spec is 8GB 1600 mhz max and 16GB 1333 Mhz max).

A little research:

Test: I installed each 16GB module individually and had same lights on no screen response.

What I want to know: Why won't the laptop boot and what do I do to get it to boot?

  • Do you have any reason to think your laptop supports 16GB modules? – David Schwartz Jan 29 '17 at 6:24
  • 2
    It probably BIOS restriction – Alex Jan 29 '17 at 6:26
  • @Alex I sent Intelligent Memory an email checking on this possibility. – forest.peterson Jan 29 '17 at 6:43
  • @DavidSchwartz yes, I do have a reason, since ivybridge supports 32GB and when this laptop was launched 16GB modules did not exist so Clevo would have no reason to specify 16GB modules, so from my perspective why not. The specs say the motherboard is limited to 1333Mhz with 16GB of ram and 1600mhz with 8Gb of ram but it is running just fine right now at 2133mhz with 16GB of ram, so spec is not everything. I am looking for an explanation for why this laptop does not support 16 GB modules. The current theory is it is a BIOS limit. – forest.peterson Jan 29 '17 at 6:43
  • 1
    @Alex you are correct, it is the BIOS. But it is a two step problem. If the BIOS table was complete, we would then find the cpu is missing circuitry. – forest.peterson Jan 30 '17 at 18:28
5

The maximum memory is often for all banks of memory being fitted. That would be 4 slots worth of memory so 4 x 8GB, the fact that laptops often only have 2 slots is irrelevant.

To explain; the processor will have 2 banks of memory and allow two DIMMs to be on that bank. They will then use a "chip select" line to select a DIMM within the bank. This allows them to cut down on the number of address lines coming out of the processor while still allowing the use of more memory.

If your laptop had 4 DIMM slots I would expect your 32GB to work as 4x8GB, but not necessarily 2x16GB as there may not be enough address lines going to the DIMM slots.


To clarify, what this means for a processor claiming to support 32GB (for example an Ivy Bridge CPU) is that it is most likely to only support 8GB DIMMs. This give the CPU its max RAM of 32GB in 4 DIMMS, and it is not likely to be able to support 16GB DIMMs.

From Wikipedia:DDR3

The DDR3 standard permits DRAM chip capacities of up to 8 gibibits, and up to 4 ranks of 64 bits each for a total maximum of 16 GiB per DDR3 DIMM. Because of a hardware limitation not fixed until Ivy Bridge-E in 2013, most older Intel CPUs only support up to 4 gibibit chips for 8 GiB DIMMs

That citation carries on to say that AMD supports 16GB DDR3 DIMMs just fine.

A newer CPU, such as a Haswell or later, CPU would definitely be able to support 16GB DIMMs (4 x 16 = 64).

UPDATE - this explanation came from the vendor:

The main problem is that the MRC (memory reference code) - which is part of the BIOS - does not support modules based on 8 Gigabit DRAM components (16GB modules consist of 8Gb components).

The MRC code reads out the memory-modules SPD-settings and finds that this module is using DRAM-chips with 8Gb capacity. Next it tries to look up the settings for the memory-controller in a table, but can not find any entries for 8Gb chips in the table.

As a result, it crashes.

If the MRC-software was modified - which nobody seems able to as the code is Intel proprietary and difficult to understand - your Ivybridge eventually might boot.

The next hurdle is a hardware limitation inside the CPU (can't get past first hurdle so this second hurdle is theoretical). Intel has said the hardware is missing in Ivybridge as well as most Haswells. Support for 16GB per module begins with 5th generation CPUs (broadwell).

  • 2
    The hardware that supports 16GB modules normally also have a maximum of 64GB. Having a maximum of only 32GB indicates you can only use 8GB modules. – Ramhound Jan 29 '17 at 9:39
  • @Ramhound 1/2 My first thought is then why would anyone make 16GB modules of SODIMM. But, I see it could be for systems that use SODIMM and have four banks, you fill two banks with 16GB modules. While that works, why you would care do that over using four banks of 8GB modules. Likely because you cannot, so there must be something more. The spec sheet for the 16GB modules lists that most any motherboard with a Haswell should accept this 16GB module. – forest.peterson Jan 29 '17 at 16:28
  • @Ramhound 2/2 The Haswell cpu is DDR4 ready and has a max of 64GB. The Haswell is capable of 16GB per bank. The ivybridge has a max memory of 32GB, indicating 8GB per bank. The intended use of this ran is for a Late 2015 iMac Retina 5K which has a Haswell cpu and four banks. Because it is is a Haswell it allows for 16GB of RAM. The intended application is not as advertised for 32GB as this would be the same as four banks of 8GB RAM. The intended application is four banks of 16GB for 64GB of RAM. This set of two 16GB modules should work nicely in a laptop with a Haswell cpu and only two banks. – forest.peterson Jan 29 '17 at 16:29
  • 1
    @forest.peterson A small bit more digging suggests that this is a fault in the memory controller on Ivy Bridge and earlier memory controllers. Ivy Bridge-E and Haswell processors correctly support 16GB DDR3 DIMMs. It is likely that this was considered a low priority bug as before 2013 16GB DIMMs would have been prohibitively expensive and largely unnecessary for the desktop market. – Mokubai Jan 29 '17 at 18:59
  • 1
    @forest.peterson there should be an "improve this answer" link beneath my answer. Otherwise post it on pastebin.com and I'll edit it in. – Mokubai Jan 30 '17 at 18:52
1

I had a similar issue today and managed to solve it by manually setting the RAM frequency and voltage.

Thought I'd add it here in case it helps anyone.

--

My hardware:

Motherboard: GA-Z68XP-UD3
CPU: i7 2600
New RAM: 4x CT102464BD160B

Steps I took:

  1. Installed new RAM:
    System wouldn't boot to bios, fans spun for a few seconds and then system rebooted
  2. Tried each RAM stick individually:
    Still wouldn't boot
  3. Installed old RAM:
    System booted fine
  4. Updated BIOS, installed new RAM:
    Still wouldn't boot
  5. Installed old RAM, reset BIOS (battery out for several minutes, checked BIOS date was reset), installed new RAM:
    Still wouldn't boot
  6. Triple checked that the Motherboard and CPU would support the RAM:
    Yep, it does
  7. Cursed manufacturers, questioned sanity:
    ...
  8. Installed old RAM, manually set RAM frequency to 1600MHz and voltage to 1.35v in BIOS, installed new RAM:
    System booted fine - woOtz!!

Sure enough, when I looked at the BIOS, something between it and the RAM was incorrectly reporting the RAM as having a frequency of 1867MHz and voltage of 1.5v.

  • The Bios in my laptop doesn't have these settings but that is progress you found a solution. – forest.peterson Jan 12 at 1:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.