1

A TP-Link TL-WR841N router has been connected with another TP-Link TL-WR845N router in WDS mode. TL-WR845N is root router here, that means it's connected to the ISP. And secondary router TL-WR841N is configured for WPS connection as described here - http://www.tp-link.com/us/faq-227.html. Actually the main intention is using the second router as repeater of root router. But the problem is if any of the router reboots, then the secondary router (which is configured to WDS) can't connect to the root router; that means WDS connection has broken and without re-configuring, it will not work. It's a very boring task to configure WDS every time if any of the router restarts. Even if I have mentioned two specific model of TP-Link router here, but actually this scenario happens pretty much most of the TP-Link routers - that after rebooting WDS connection can't reconntect automatically.

  • 2
    did you try fixing wireles channel of main router? Auto channel option in mainrouter could cause breaking wds between 2 devices – User Apr 16 '17 at 22:09
  • 1
    Thanks, @User .Changing from 'auto channel option' to 'fixed channel option' in main router solved the problem. – DAF May 12 '17 at 11:07
1

Here is the full solution that worked for me with a TP-Link router, for completeness - step 1 was already posted in the comments, but it may not be obvious to everyone that it can be fixed without a factory reset:

  1. Set the wireless channel for the wifi network you are using for the WDS, on the primary/internet-connected router, to a fixed channel - not auto-select.
  2. Because you don't have any DHCP on the secondary router, and the WDS is not up to relay the DHCP from the primary router, you can't connect to the secondary router in the normal way if you normally use DHCP (which most people do). The solution, if you have this problem, is to remember that its IP address is statically set to 192.168.1.1 with netmask 255.255.255.0 (at least, this is the case on my TP-Link router). So connect to the secondary router but with a temporary static IP address assignment to something on the same network but different, e.g. 192.168.1.64. If a wifi connection doesn't work, try connecting using an ethernet cable.
  3. Log in to the secondary router web admin page (again, this should be on 192.168.1.1 - because you don't have DHCP, you won't be able to use any DNS, unless you have it set in a hosts file on your client). Set the channel for the wifi network you are using to the same channel as the one you set in step 1.
  4. If you changed your IP address configuration in step 2, reconfigure your IP address for the secondary router connection to be automatically allocated using DHCP again, on the client.
  5. Disconnect and reconnect. Everything should now work - and it should work after a router reboot as well.

Note: this problem and solution is independent of which router you are using for the primary router - my primary router is not a TP-Link router.

| improve this answer | |
  • Making wifi channel fixed solved the problem. – DAF Aug 24 '18 at 15:24
  • It seems I have the same issue. haven't been able to solve it yet. Full details here superuser.com/questions/1410674/… – krv Mar 2 '19 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.