0

ASRock z270

2x 8GB Crucial DDR4 3000mhz

GTX660TI (old! D:)

It's a basic setup, for my little brother's first gaming setup. Everything when fine during the setup, with one odd hiccup. The PC only boots with one RAM stick. I know how to insert them into the proper slots, and made sure they are seated properly. Troubleshooting I've tried;

Both RAM sticks work fine. It doesn't matter which one I use.

Every slot works fine (with just one in it).

It doesn't matter if I use A or B slots, or if I try to mix, just for fun.

I even tried inserting RAM stick two while it was running, then restarting the PC. It worked, but only recognized one stick. That was odd, too.

If there's more than one stick, the PC won't even get to the point where the monitor light goes green and it initiates BIOS. I've reset CMOS and tried just about every troubleshooting step I can think of, but it simply will not allow two RAM sticks. Any ideas? Thank you all so much!

0

Wow inserting RAM while PC running? Brave (stupid) step.

First are u really sure, that your mobo dont care about used RAM slots for two modules? Check your mobo manual or specifiy the model so i can take a look. There should also be list of supported memory modules, this or very similiar modules should be present.

Second check both your modules for supported modes (frequencies, timings, voltage) by using cpu-z for example. Then go to bios and force some lower mode for them that you found in cpu-z. I think some 2400MHz should be ok.

Third, there are more possibilities from bad PSU unable to provide enough power, through bad MOBO to bad CPU.

My final advice, RAMs are not plug'n'play, insert/extract them when PC is completely cut off from power, no LED on mobo shines.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.