0

I recently updated my laptop (a Thinkpad T460p) to the Windows 10 15019 Insider Preview from the previous Insider build. Before the update, my laptop was whole-drive-encrypted with Bitlocker, and had its fingerprint reader set up to allow sign-in with fingerprint (Windows Hello).

After the update, however, I noticed that it was no longer prompting me for my Bitlocker password at startup (and fingerprint sign ins didn't work). I went to Bitlocker settings and saw this:

Bitlocker settings page

Clicking "Resume Protection," however, results in an error:

Resume protection error

And looking at the TPM Management program claims there is no TPM present:

No TPM present

And, finally, Device Manager claims the TPM 2.0 chip failed with code 10 - "The resource requested is already in use:"

Device manager error

I've tried disabling and re-enabling the TPM in my BIOS (it says it's something along the lines of an "Intel PTT 2.0"), with no success.

Has anyone run into this problem or have an idea of how to fix it? I'll probably roll back to the earlier build tomorrow, but if there's a way to fix this issue without going that far I'd much prefer that!

Also - I haven't yet tried the "Clear Keys" option in the BIOS. Am I right to worry that if I do that I might have issues unlocking my Bitlocker drive?

Thanks in advance!

  • 1
    DO NOT DO ANYTHING with your system in this current state! Unless you Turn Off Bitlocker first. I suspect your problems are because of your build update, it happens with Insider Preview builds, turning off Bitlocker then turning it back on is your safest choice – Ramhound Jan 29 '17 at 23:19
  • Great advice - I'm going to decrypt my device right now. Thanks! It also looks like this is a very common problem with this build, from comments in the 'feedback hub'. – MatthewSot Jan 29 '17 at 23:21
  • 1
    I would suggest rolling back, if it's possible, once you turn off Bitlocker. You can then see if your TPM device starts working again. – Ramhound Jan 29 '17 at 23:27
  • Huh, interestingly my BIOS allows me to switch between an "Intel PTT TPM 2.0" and a "Discrete TPM 1.2." I tried switching to the discrete TPM (after decrypting), and it seems to be recognized by Windows. I'm still going to hold off on re-encrypting the drive for the next few builds, but until then this should let me use the fingerprint reader. Thanks for the help! – MatthewSot Jan 29 '17 at 23:56
  • Matt - Does this mean Ramhound should add that as an answer for you to accept for this particular inquiry? I'd give it +1 if so just curious what your thoughts are on those comments and the potential for that being added as an answer by Ramhound himself for you to accept? Have you every seen a computer that's been shot by a slug shot 12 gauge? I have; lol – Pimp Juice IT Jan 30 '17 at 0:47
0

We got the same problem with Lenovo, we reset even one of our test computers back with clean installation to 15002, checked the tpm in device manager but it was yellow, downloaded by windows updating driver and it was ok, then we updated to 15019 again and we are back with yellow tpm, driver do not work, tried to download but windows says the driver is ok. We tried before we reset to go to bios disable tpm and restarted and enable tpm again in bios but it did not help, we tried several attempt with other solution intel driver, lenovo driver but no. It is the update 15019 which have error in the driver for tpm. we have disabled the tpm as time being and waiting for ms to come with next build where prob. they fix it, many have this problem after updating. due to this pin do not work. We updated a home version in another pc and it was no problem even home does not have tpm, but under device manager you have tpm and driver is not marked with yellow.

  • Johan, a little formatting would make this answer much easier to read. – music2myear Jan 30 '17 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.