3

I just installed Windows 10, after years spent with Windows 7.

Drag & dropping a .wav file into SoundForge is something important in my workflow. Why doesn't it work anymore in Windows 10?

Maybe linked: why the shield icon on the SoundForge shortcut? I tried Properties > Shortcut > Advanced > Run as administrator ON or OFF, it's the same.

PS: I'm using Windows 10 Pro, with a single user account (I'm the administrator).

enter image description here


I also tried administrator ON/OFF in Properties > Compatibility, but it's also the same.

enter image description here

13
  • 1
    It probably does have to do with that Sheild on the icon, but the problem isn't that it is on the icon, but that the program is for some reason required to run as admin. A program running in administrator mode will not be able to receive drag and drops from a program not running as admin, Commented Jan 30, 2017 at 3:14
  • You may try the answer here superuser.com/a/547846/368970 Commented Jan 30, 2017 at 3:23
  • I only have one user : myself, and this user is Administrator. UAC is already in its lower state (slider low position). But still doesn't work
    – Basj
    Commented Jan 30, 2017 at 8:40
  • This does not have to do with how much users you have on your PC. In you own user some programs (most of them) run without needing admin right and some do require admin rights. Drag and drop doesn't work between these two types of programs. Turning down UAC (which is a bad idea as its own) does not mean it'll not run as admin just that it won't ask you permission every time to do that. Commented Jan 30, 2017 at 12:43

3 Answers 3

8
+50

You see a effect of the User Account Control. Drag & Drop only works for programs that have the same permission level. If you run an application as admin, you can only drag and drop files from applications that also run as admin.

User Interface Privilege Isolation (UIPI)

UIPI blocks Windows messages being sent from process with a lower MIC level to one running at a higher MIC level. Drag-and-drop is implemented via Windows messages. Therefore, if you try and drag-and-drop a file from Windows Explorer (medium MIC) to Notepad running elevated (high MIC), the Windows messages are blocked and drag-and-drop doesn’t work.

Moving the slider down to the lowest position no longer disables UAC since Windows 8, because UAC is required to use the store apps, because UAC provides the sandbox in which the apps run isolated.

The version 8 is very old, so Windows detects that it has issues running under normal user permissions and requires admin rights.

As mentioned above this is a feature that can't be fixed. But there is a workaround to run Explorer as admin to be able to drag & drop files from Explorer to a process running as admin.

13
  • yes, you can run Explorer as admin and drag&drop them from here: superuser.com/a/1060578/174557 Commented Jan 30, 2017 at 19:13
  • use app compatibility tools (part of Windows Assessment and Deployment Kit (ADK)) to alter the shim for SF8 to run "AsInvoker" Commented Jan 30, 2017 at 19:19
  • 2
    as I said, moving the slider no longer disables UAC since Win8, so that is why you don't see this in Win7. no, you don't know what you do, otherwise you wouldn't ask here ;) Commented Jan 31, 2017 at 20:02
  • 1
    @Basj I've added it to the answer. Commented Jun 17, 2020 at 15:08
  • 1
    Ok @magicandre1981, I posted it as a new answer with a few remarks, for future reference. Full credit to you, I just awarded you the bounty.
    – Basj
    Commented Jun 19, 2020 at 15:37
2

I have this exact same issue with an older version of Wavelab and my only workaround is to drag and drop onto the Wavelab desktop icon shortcut. For some reason this opens the file in the program as normal and can also be used to add more files into it while running.

0
0

As posted in a comment from @magicandre1981 (to whom I'll give bounty of course, credit to him), another solution is to use RunAsInvoker as mentioned in http://meridian.ws/wordpress/?p=306 and http://www.ghacks.net/2010/07/08/get-rid-of-uac-prompts-with-microsofts-application-compatibility-toolkit/.

Here is how it goes; I used a similar method to previous links, but with a few slight differences (point 6 was not mentioned in these articles, it was needed for me).

More precisely:

  • Download ADK (Windows Assessment and Deployment Kit) from here and install ACT

  • Launch Compatibility Administrator (32 bit, in my case) and create a new Application fix:

  • Choose the SoundForge 8 executable path, and add RunAsInvoker:

  • Auto-generate in the next step:

    enter image description here

  • Save the Database (File > Save As) somewhere. Then File > Install it.

    enter image description here

  • In the Properties of "Forge80.exe" (right click on it), uncheck everything related to Compatibility mode (this was necessary for me)

  • Delete the original shortcuts, and create new shortcut on your desktop if necessary

  • It works!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .