9

I recently started using a Surface Book (This doesn't appear to be happening on my Win10 desktop). An application had text so small it was impossible to read, even when outputting to a large display:

enter image description here

I tried changing the font size in settings, and running sfc /scannow to check for corrupted system files, but neither fixed the issue.

I also considered that it was just the one program, but after encountering this on another application, I realized - after some research - this is a problem with Windows 8 apps running on Windows 10, but only on specific displays or possibly display settings.

This is probably happening for all surface users, as well as other laptops. [Source]

2 Answers 2

11

I fixed the problem following steps 1. and 2. of @Travis but changing in step 3. So:

  1. Make sure the application is running

  2. Right-click on the icon in the task bar > properties

Properties menu

  1. Tick Override high DPI scaling behaviour. Scaling performed by: and then select System (enhanced).
2
  • 2
    This worked for me. May 28, 2018 at 0:47
  • 2
    Perfect this saved my day.
    – Garry
    Aug 31, 2020 at 17:40
6

It took quite some time to dig up the solution on the Microsoft Message boards, so I figured I'd go ahead and post the question & answer for anyone else that may need it.

1. Make sure the application is running

2. Right-click on the icon in the task bar > properties

enter image description here

The SAS Enterprise Miner software is a special case. After right-clicking the icon I had to right-click on the Java Web Launcher to get to the Properties.

3. Go to the compatibility tab > Disable display scaling on high DPI settings

enter image description here

4. Restart the application

5. The text should be a readable size now.

enter image description here

Note: I have a feeling there is another setting to fix this problem without having to do this for every application affected by it, although I have not found that answer yet.

4
  • Setting "Change the size of text, apps, and other items" in "Display Settings" to something like 200% wasn't enough? Jan 30, 2017 at 6:09
  • Yes, see the source I cited, a lot of people have the same issue. Jan 30, 2017 at 14:43
  • 1
    Travis, thanks for pasting the solution it worked for me with little bit of difference. In task bar items i didn't got the properties to enable DPI settings. Instead in the desktop icons I right clicked and then to properties and then compatibility. Desktop Icon --> Right click-->properties --> Compatibility--> Enable DPI settings option (In fact, it is disable display scaling on high DPI settings)
    – Ajeya S
    Oct 6, 2017 at 9:56
  • 1
    Currently, the settings for this can be found under Compatibility Tab > Settings Section > Click "Change high DPI settings button > Tick "Override hight DPI..." checkbox > Select "System (Enhanced)" option from drop-down list.
    – Rafe
    Oct 21, 2018 at 10:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.