1

My display was at a very low resolution (1024x768) , so I added a higher resolution manually using xrandr for my BENQ G2420HDB, which is supposed to have a native resolution of 1920x1080. I succeeded in changing the resolution, but subsequently, the display did not fill the screen; the edges of the monitor were black. Pressing the "Auto" button on the monitor made it worse, such that part of the display was invisible. I manually changed H. Position, V. Position, and Pixel Clock. This has made the black edges smaller and I can see the entire display, but now I get flickering when I have (rapidly) moving images (scrolling, changing desktops, video, etc.). My monitor is connected with a VGA-DVI-adapter to an AMD/ATI RV620 HDMI Audio (Radeon HD 3400 Series) graphics card.

To install the new mode I used:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync && \
xrandr --addmode DVI-0 1920x1080_60.00 && \
xrandr --output DVI-0 --mode 1920x1080_60.00

Subsequently, xrandr shows:

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      60.00  
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
   1920x1080_60.00  59.96* 

What may cause the symptoms I described? Is the resolution I'm trying to set wrong? Or does this point to a hardware problem with graphics card, monitor, or perhaps even the adapter?

2 Answers 2

2

According to your graphics card's specs and your display's specs, both support digital DVI output and input, respectively.

Based on the manual picture adjustment you mentioned, you seem to be converting from the digital DVI signal to an analog VGA signal. Don't do this if possible.

First Recommendation

Use a DVI-D or DVI-I cable to make a direct digital connection from the graphics card to the display.

With a digital signal, you won't need to calibrate the image because the display knows where the pixels are supposed to show. Also, the flickering should go away because you won't be using the possibly problematic conversion from a digital signal to an analog signal.

You'll also end up with a better overall picture because of the various other advantages of using a digital signal.

Second Recommendation

If for some reason you must convert from a digital signal to an analog VGA signal, there is a hit-or-miss software thing you can try:

  1. Generate a VESA CVT mode line with reduced blanking:

    cvt --reduced 1920 1080 60
    

    1920 is your desired width, 1080 is your desired height, and 60 is your desired frequency in hertz. Your output should look like this:

    # 1920x1080 59.93 Hz (CVT 2.07M9-R) hsync: 66.59 kHz; pclk: 138.50 MHz
    Modeline "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
    
  2. Create a new mode with the mode line you just got from the cvt command:

    sudo xrandr --newmode "1920x1080R"  138.50  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync
    
  3. Add the mode to your display output:

    sudo xrandr --addmode DVI-0 1920x1080R
    
  4. Use the new mode:

    sudo xrandr --output DVI-0 --mode 1920x1080R
    

I say this is a hit-or-miss approach because it could simply be that your DVI to VGA adapter cannot cope with the high-resolution conversion. Reduced blanking might help free up bandwidth for the adapter, but we can't know for sure without trying it.

2
  • My new DVI-D-cable arrived. It recognises the right resolution (yay!), but I still have problems with flicker/content not getting refreshed correctly…
    – gerrit
    Feb 7, 2017 at 21:19
  • However, I managed to get rid of the flicker by going into System Settings → Hardware → Display and Monitor → Compositor, and switching it off. I will post that as a second answer.
    – gerrit
    Feb 7, 2017 at 21:25
0

Deltiks answer solved one part of the problem: after using a DVI-D cable, the display is identified correctly.

The flicker remained. Finally, I managed to get rid of the flicker in KDE by going into System Settings → Hardware → Display and Monitor → Compositor, and switching it off. Now everything seems fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .