1

On my Lenovo Yoga 500-14ISK running Windows 10 Home, I am experiencing weird keyboard issues, some of which are listed below:

  1. Double clicking on items in Windows Explorer opens the properties dialog (Also reported without any proper solution here.)

  2. Sometimes in Firefox, everything works as if the Control and Shift key is stuck. I cannot use these keys at all. Interestingly, the keys are not really stuck since reopening Firefox gets rid of the issue.

  3. In some other programs, (especially Spyder), some keys sometimes function as if the Ctrl key is pressed down, even if I haven't even touched Ctrl.

I have tried a full recovery without any luck.

I dual boot and the problem never seems to occur under Linux. Also, it mostly occurs only after extended use.

  • 1
    I suggest using software that can log which keys are pressed. It won't solve your issue but it will help you to understand it. Here's an online key even listener: unixpapa.com/js/testkey.html Keep in mind that the webpage needs focus for it to listen to your keys. So if SHIFT is stuck down before you give the page focus, it probably won't report it, but you'll be able to see if it doesn't report letting go of SHIFT when you manually press and let go. – Bort Jan 30 '17 at 15:11
  • 1
    "I have tried a full recovery without any luck." - This indicates a hardware problem. – Ramhound Jan 30 '17 at 15:19
  • 1
    @RadialApps - You shouldn't worry about a single downvote. If you get more then one, that indicates a problem with your question, you should take that to mean you should improve your question. It also appears, based on your recent reputation history, your a possible victim of a serial downvoter. If that is the case, the votes will be reversed, which is another reason you shouldn't worry about a single downvote. – Ramhound Jan 30 '17 at 15:22
  • @Ramhound, I was thinking about the hardware, but the fact that it never happens under Linux refrains that thought. – PulseJet Jan 30 '17 at 15:37
1

Just in case anyone stumbles across this, the problem in my case is a bad right Alt key (some keyboard defect), which explains everything. Incredibly, the key gets into a pressed state even if I never touch it. Double tapping the key brings it out of this state and everything starts working as before!

The fact that this doesn't happen under Linux still somewhat perplexes me though ...

0

Run it in safe mode and see if the problem is still there. Its possible your system is infected. Safe mode won't guarantee the infection is not loaded, but is a good starting point to isolate issues.

  • Can't really test out things in safe mode much, since it occurs only after extended hours of use (I'm adding this to the question). Also, it is unlikely to be a infection, since a full recovery (clean) didn't help, as I mentioned. – PulseJet Jan 30 '17 at 15:04
  • 1
    Oh, i took your recovery as an reinstall without format. Apologies. Its may be an app you are using. Some macro or something acting up. – robx Jan 30 '17 at 15:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.