0

I have a laptop (Toshiba Portege Z30-C) where I dual boot between Windows 7 Pro and Linux Mint 18. Today, in an effort to test a bootable USB, I changed the boot BIOS from "UEFI (legacy)" to "CSM Boot". After changing BIOS settings back to "UEFI (legacy)" grub is no longer loaded, and it goes straight to the windows loader. When I hit F12 for boot override, I only see "HDD" as an option, and I presume that's what leads to a windows boot.

Before the change, I remember that the BIOS included "Ubuntu" in the list of bootable devices. Now, however, it seems to have forgotten about my linux installation with no apparent way of getting ubuntu (referencing grub on one of the partitions, I presume).

Nothing has changed on the linux partition, and as far as I know nothing should have changed on the boot partition either. How do I get my linux distro back amongst the bootable "devices" in BIOS?

From what I can see in windows' partition tool, all partitions are as they've always been.

  • 1
    On newer PC's with UEFI there is a list of "trusted" boot images, and the list may be lost (e.g. after a Windows update). Though this video is for an Acer, it may be applicable to the Toshiba:youtube.com/watch?v=XtXnQpv5Zqw . Hope this helps. – DrMoishe Pippik Jan 30 '17 at 18:12
  • @No windows updates were running. In fact, I hadn't booted windows for months until after this happened. It was caused purely by changing the BIOS settings to CSM boot. However, I've posted the solution to my problem below. Thanks for your input. – Jarmund Jan 31 '17 at 13:40
0

Something similar happened to me once. I was able to fix it by booting to a CD just to get a better boot menu and then I was able to boot to my Linux OS on the disk from the menu the CD provided. Then I just fixed Grubs boot. I do not know the ins and outs of why Windows does this. This was many years ago too so ymmv.

0

Turns out that setting the BIOS to CSM dropped any uefi entries other than the windows one that came with the laptop. The fix was to boot windows and re-add the entry manually by using bcdedit from windows' dos-prompt:

#List the entries to find a usable one to start from:
bcdedit /enum firmware

#Copy the usable entry to a new one with an appropriate name:
bcdedit /copy {bootmgr} /d "Mint UEFI boot"

#The previous command returns the guid of the new entry. This entry goes into the next command where we edit the new entry to point to the ubuntu firmware.
bcdedit /set {guid_goes_here} path \EFI\ubuntu\shimx64.efi

#Optional: Set the new entry to be the first choice when booting:
bcdedit /set {fwbootmgr} displayorder {guid_goes_here_too} /addfirst

Once this was done, everything was back to normal. No other changes were needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.