0

I am attempting to get the following network to work:

BT Homehub (primary router, upstairs) <--- powerline (TP Link AV1200) -- -- powerline (TP Link AV1200) --> Sky SR102 (secondary router, DHCP off - downstairs)

I want the Sky router to broadcast wifi signal downstairs as a sort of "repeater." I have followed these steps:

The SSIDs for both networks are not the same.The primary router's range is 192.168.1.X

Problem: Although the network connects and all powerline adapter lights are green, I am experiencing frequent drops in connection downstairs to the point where I either have to reconnect to the Sky's network or select primary router's network to connect. Speedtest shows the same connection speed as before. Changing the channels (6 and 11, 7 and 11, 11 and 11 - 1 is too crowded in my vicinity) didn't help at all. I have tried to set a constant ping to the primary router (read somewhere it could help with the drops) but it didn't change anything either. I am also unable to reach the secondary router either by its new IP or factory IP address so I can't change its settings at all. Also not all of my devices will connect to the secondary router network.

Any ideas??? It feels like the two networks are cancelling each other out, but I don't understand why, I have tried to google the issue but came up emptyhanded.

EDIT: The default IP range of the primary router is 192.168.1.64 - 192.168.1.253

Thanks

  • What does the TP-Link powerline app say about the link quality? – user1686 Jan 30 '17 at 19:04
  • Also, the reason you can't reach 192.168.8.10 is because neither your PC nor its default gateway (router 1) know anything about that subnet, so the packets just go towards the ISP... (That site's recommendation was somewhat unnecessary.) So temporarily set a static IP address on the PC. – user1686 Jan 30 '17 at 19:07
  • Thank you for your replies. I am on Ubuntu as a main system so I don't have the app. I can try installing it on windows and see what it says. – renifer7 Jan 30 '17 at 19:16
  • Re static IP, I tried (I think) to set a static IP like here: 2ellsblog.files.wordpress.com/2016/02/… by selecting Always use the same IP, but I'm not sure that it worked. :/ – renifer7 Jan 30 '17 at 19:18
  • open-plc-utils should work; use plctool -i wlan0 -m all or int6kstat -i wlan0 -t. – user1686 Jan 30 '17 at 19:19
-1

As the SR102 doesn't have an ethernet WAN port it can't route between your 2 subnets. You need to put it on the same subnet as the HomeHub i.e. 192.168.1.X

Example settings:

HomeHub LAN settings (I think these are the defaults on the HomeHub): - IP 192.168.1.254 - netmask 255.255.255.0 - gateway 192.168.1.254 - DHCP ON - DHCP range 192.168.1.1 - 192.168.1.200

On the SR102: - IP 192.168.1.253 - netmask 255.255.255.0 - gateway 192.168.1.254 - DNS 192.168.1.254 - DHCP OFF

Note the SR102's fixed private IP address is outside the HomeHub's DHCP pool, to avoid IP conflicts.

Initially you can try having both routers on the same SSID and other wifi settings. I'm not sure if these 2 routers would get on well together for wifi handover etc., if they don't then go for a different SSID on the SR102. Wifi channel is probably best left to auto on both. Good luck!

  • Chris, you should merge your two acconts together. – Ramhound Jan 30 '17 at 21:48
-1

P.S. based on you existing HomeHub settings, just put the Sky anywhere between 192.168.1.1 to 63 and should work. The Sky won't let you configure a LAN gateway so you won't be able to log into the Sky after doing this (so do the wifi settings before the IP) the link should work. You will need to reset the Sky to factory settings if you want to log into it again.

  • Chris, you should merge your two acconts together. – Ramhound Jan 30 '17 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.