0

Hello everyone!

I have the following problem: my laptop refuses to boot. When booting to Windows, it gets stuck at loading CLASSPNP.sys, on Linux its some ACPI error (dont have the exact logs atm, I can post them later if needed | it boots with failsafe mode enabled). The same goes for any Live-OS or Install disk which uses ACPI. After some digging I have found that the most probable source of this problem would be a broken / corrupted BIOS, so I wanted to update it (its fairly old as well). Long story short, since I cannot boot into Windows and American Megatrends doesnt offer their AFUWin / AFUDOS Software for linux, I created myself a FreeDOS USB Drive and tried to update the BIOS from DOS. Everything works as it should, except for the ever so slight issue that AFUDOS complains about a write-protected BIOS, then freezes and has to be hard-resetted. Since the laptop is some no-name brand and nowhere to be found on the internet and the mainboard turned out to be unidentifyable, even after opening the device, I am not even sure whether or not I am using the right tool at all... (BIOS is an American Megatrends one, Version 2.14.1219). I tried to locate the BIOS Chip and look it up, maybe I could short two pins and make it writable, but found myself unable to locate it at all.

What should I do? I'm really out of ideas now...

Thanks in advance, Tim

  • PNP (Plug and Play, ISA legacy) components are defined in the ACPI data, so it's likely that the ACPI data is corrupted. I think it should be possible to tell Linux to override most of the ACPI data in one way or other, but the boot logs are necessary for that. So at least you should be able to continue using it for Linux. If the BIOS and/or BIOS flashrom is so broken it won't allow flashing, then it looks like you can't repair the BIOS. Don't try to flash a BIOS that's not made for your laptop, you can completely break it that way. – dirkt Jan 30 '17 at 21:09
  • Well that doesn't sound too good... I have tried booting it with the acpi=off noapic nolapic options and everything works fine, except for the battery monitor and power management... – rocket_doge_ Jan 31 '17 at 6:33
  • (which was kind of expected given that I disabled ACPI) – rocket_doge_ Jan 31 '17 at 6:33
  • So that sounds good. Boot with ACPI enabled, look at what goes wrong (boot logs), and try to only disable/overwrite the part that is broken. This way, you should be able to salvage battery/power management somehow (unless this is what's broken). Also, use acpidump and iasl to have a look what the tables are (tables may changing according to acpi_osi value on boot), so you can get an idea what's wrong. – dirkt Jan 31 '17 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.