After a reboot my Debian Server don't want to boot anymore.

Loding the Kernel Modules nfsd and ext4 fails with the following errors (in dmesg):

nfsd: Unknown symbol setattr_prepare (err 0)
nfsd: Unknown symbol set_posix_acl (err 0)
ext4: Unknown symbol setattr_prepare (err 0)
ext4: Unknown symbol posix_acl_update_mode (err 0)

I've tried to reinstall the kernel and to downgrade the kernel, but that doesn't help. It's a debian Jessie with all updates installed.

  • What version of Debian? Do you have boot over PXE or it's a purely local install? I mean this which basically means out-of-sync kernel and other images it uses to boot (early userspace and so on).
    – kostix
    Jan 31, 2017 at 6:36
  • In either case, consider posting a message to debian-users -- you don't need to be subscribed to post but ask for Cc'ing you on replies.
    – kostix
    Jan 31, 2017 at 6:37
  • Same problem here when modprobe btrfs. I tried rebuilding linux-image-3.16.0-4-amd64 package without CONFIG_BTRFS_FS_POSIX_ACL, no difference.
    – alexei
    Feb 12, 2017 at 0:25

1 Answer 1


Problems like this are most commonly after kernel upgrades, recompiling, or playing with boot loader configuration. The most probable reason is that you are not running the kernel version whose modules are in /lib/modules.

Debian does not use the third "patch" level in directory name anymore, so different kernels with different symbols may end up in /lib/modules/MAJOR.MINOR.0-XX-arch/.... See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=866336

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.