3

I'm running python server.py using bottle server

I follow https://stackoverflow.com/questions/19688841/add-python-to-os-x-firewall-options and add which python and which python3 to keychain

Everytime I run bottle server I get same box popping up. I also added pass in proto tcp from any to any port 8080 to /etc/pf.conf

My bottle file is like

import bottle

bottle.TEMPLATE_PATH = ["static", "views"]
app = bottle.default_app()

app.run(host="0.0.0.0", port=8080, reloader=True, debug=True)

so now anytime I update the server, when a request is made, I get the popup

How can I stop this popup? Thank you

1

You may need the --deep flag... Compare the answer https://apple.stackexchange.com/a/121010/6126 which works for me:

# Re-signing an app: 
codesign -f --deep -s <certname> /path/to/app
# Verify that it worked: 
codesign -dvvvv /path/to/app

(Note that you need to accept the dialog one last time)

1
  • I upvoted as it was an important tip - but it still doesn't work on macOS Mojave ... – Agile Bean Dec 4 '18 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.