0

When I am using my laptop, there are no WiFi problems whatsoever, yet when I lock it and close the lid, the internet connection stops working after a few minutes.

Some additional info:

"the internet connection stops working" means:

  • Both the router, and the laptop say they're connected to each other, but I am unable to find the Laptop using a network scanner on a different device.
  • The laptop has no internet connection, and is unable to send (or receive) any TCP packets (even to the router)

The machine is set to keep running, when the lid is closed. I disabled all energy saving functions, which were in any way related to networks. My wireless card is a Qualcomm Atheros QCA61x4A Wireless Network Adapter (I updated the driver today). I suspect the problem isn't directly linked to the router, since I was able to reproduce this issue with a different WiFi router from a different ISP. My OS is Windows 10 Home, with the latest available BIOS. This is my ipconfig, in case it helps http://pastebin.com/tE0rqeCx Interestingly I noticed that these issues arise only when the laptop's lid is shut, when open it works fine.

Please tell me if you have any suggestions as to how to resolve this problem, it would be greatly appreciated. (Especially because it makes Teamviewer useless) Please bare in mind that I am no expert when it comes to networking.

0

Both the router, and the laptop say they're connected to each other, but I am unable to find the Laptop using a network scanner on a different device.

It's not from your router for sure!! check your wireless card setting, maybe it's on "save power" you can find the setting from:

control panel>device manager>Network Adapters> Right Click > properties > Advanced > and check if there is setting there for save power

Sometimes you can find the save power option in different tap "power management"

Also check the BIOS, some laptop have that option there Go to BIOS then check the power management

If this problem still exist update your BIOS or check if there is any updates for your wireless card. check this option enter image description here

  • I'm afraid I had already disabled ALL power saving options. Also I'm already running the newest available BIOS version (it's a new laptop) and there is no option for power management in the bios. Thanks anyway – Sebastian Hietsch Jan 31 '17 at 19:37
  • There is something interesting I did notice though: When the laptop is only locked, without shutting the lid it works fine, only when closing the lid, problems arise – Sebastian Hietsch Jan 31 '17 at 19:40
  • Check the options again windows 10 can be tricky i suggest check the wireless power management option from inside the bios and from device management, it's normal because when you lock the screen on windows 10 it do nothing, but when LED close it will trig the save power – Narzan Q. Jan 31 '17 at 19:43
  • Nope, didn't work. And like I said, the BIOS has no power management option. – Sebastian Hietsch Jan 31 '17 at 19:53

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.