0

With lspci I get the name of my network controller:

03:00.0 Network controller: Intel Corporation Device 3166 (rev 99)

With modinfo iwlwifi | grep 3166 I get no results which means that iwlwifi does NOT support my newtork controller. How can I get my wireless to work?

UPDATE

I editet my /etc/apt/sources.list and run apt-get -t jessie-backports install firmware-iwlwifi. Wireless still does not work..

INFO

  • Debian: 8.7 (jessie)
  • Kernel: Linux 3.16.0-4-amd64
  • Looks like it's supported for newer versions of iwlwifi, which means you must upgrade your kernel. This might require a newer Debian distro. Or you can try to find the correct backport. – dirkt Feb 1 '17 at 12:32
  • @dirkt Thank you! I editet my question. How can I procede? I would prefer the backport.. (if it doesn't work I can try to upgrade my kernel) – Michael Käfer Feb 2 '17 at 20:45
  • Googling for "debian jessie kernel backports" finds this with kernel version 4.9 available. That's a bit more than 3.16. You need to upgrade the kernel, as I said. Upgrading the firmware is not enough. – dirkt Feb 3 '17 at 7:40
  • I did apt-get install -t jessie-backports linux-image-4.9.0-0.bpo.1-amd64. On reboot I get a black screen with a white cursor on the left upper corner... When I hit the reset button, my machine boots again, I can interrupt the booting and select my old kernel.. – Michael Käfer Feb 3 '17 at 9:53
  • Debugging kernel boot issues it probably a new question. Black screen points to trouble with the graphics card/framebuffer driver. Google for kernel options you can pass on boot to narrow down the problem. It's also possible that the kernel expects certain packages; see if there are docs about the backport. Eventually you'll have to upgrade the kernel at some time, anyway. – dirkt Feb 3 '17 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.