This is driving me crazy. For some reason Windows 10 is showing me the UTC +00:00 London time instead of UTC +01:00 Vienna although I set it accordingly:

enter image description here

If I disable "Set time automatically" and re-enable it, the time gets set correctly. However, after I reboot, the time is wrong again. Yes, I've tried to change the time-server and I've also tried to "set time zone automatically" but I'm still getting the wrong time.

How can I fix this annoying issue?

  • 1
    Are you able to ping, time.windows.com, the default NTP server? What region do you have your installation set to? We are currently in DST, and you have it enabled, are you 100% sure your time zone is actually changing?
    – Ramhound
    Feb 1, 2017 at 21:47
  • @Ramhound Interesting - I get a time out if I ping time.windows.com - why is that? I am quite sure that I set my installation to Vienna, but even if not, I, the user, demand to see the time in UTC +1. What do you mean by "time zone is actually changing"? Feb 1, 2017 at 22:59
  • So if you want to manually use a time zone, disable, "set time automatically". So answer my question about your regional settings. In addition, tell us, what time that region is considered to be in. What I am asking, are you sure, your time zone is changing instead of your clock being off by one hour. I have no idea, the reason you cannot communicate with time.microsoft.com, try some other NTP server.
    – Ramhound
    Feb 1, 2017 at 23:02

7 Answers 7


I had a similar problem on Dual Boot PC (Win 10 & Ubuntu 18.04). The issue was that Windows tries to keep hardware clock (a.k.a BIOS clock) at the local time, but Ubuntu tries to keep it at the UTC time. So the OSs fight each other, changing the hardware clock time each time they boot.

The solution is to either make Ubuntu use local time, or make Windows use UTC time. If you use Ubuntu 15.04 or newer, then I recommend the first option, because it's as simple as executing a single command:

timedatectl set-local-rtc 1
  • THX a lot - solved the issue completely.
    – Henrik
    Sep 23, 2018 at 18:19
  • This should be the accepted answer. I made win10 use UTC time, because timedatectl remarks that it is adviceable to keep rtc in UTC-mode.
    – Ini
    Jan 24, 2019 at 21:54
  • Amazing! Thank you so much!
    – Flimm
    Apr 14, 2022 at 9:21

Do you have dual boot on your computer? I've had the same issue before and how i fixed it was to change something in GRUB customizer.There's also a way to change it in windows so it might help you!

Anyway this might help


I had the same issue.

(also windows 10, ubuntu dual boot)

Turned out the date was wrong in the BIOS settings.

Changing it there fixed the issue


I had a similar problem with a dual boot Windows 10 and ubuntu machine. Even though the clock was correct in the BIOS, and the time zone was correct in Windows, the clock was always one hour behind in Windows after rebooting. The only thing that reliably fixed it for me was to change the internet time server to pool.ntp.org. Neither time.windows.com nor time.nist.gov worked after reboots. I'm in the UK.

Also, make sure the Windows Time service is set to start automatically.


Open "Control Panel", click on "Clock, Language and Region", click on "Date and Time", select the "Internet Time" tab, select time.nist.gov from the dropdown, click "Update now".


This works for me.

  • Press Windows key + R
  • Type services.msc.
  • Double Click "Windows Time" in the Name column.
  • Change "Startup type" to "Automatic" (if it’s not already set to Automatic).
  • Click Start if the service isn’t started.
  • Restart PC

Hope this help image


Another option is to use Dimension 4 app on Windows, which will automatically set the correct time:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.