0

My Windows 7 Machines, when idle, ficker the HDD activity light pretty much dead on once per second. The machines have been running for a while, so there's nothing loading or running in the background that should be causing it.

I've already tried the suggestions in Why does my hard drive LED light blink every second? and Why does the hard drive light blink once per second? - Neither work. (I don't have a broadcom card reader, and it's happening on two different machines)

I've:

  • turned off Autorun via the control panel
  • disabled the services\cdrom\autorun key
  • adding "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\PerfDisk\Performance\Disable Performance Counters"=1
  • run diskperf -N
  • opened Process Explorer and watched for any processes causing it

I once fixed it before by a command similar to the diskperf command, but I've since been unable to find the command, or it's stopped working.

It's happening on my gaming machine (Xeon E3-1230v2, Sandy Bridge board, W7x64) and a random laptop I've got (HP Elitebook 2530p, C2D L9400, fresh install of W7x32). Both have SSDs and ODDs.

I believe it's something like the disk statistics system - if it is polling the disk to gauge the latency or something how do I disable it?

3
  • It seems from your question that you have some kind of problem or issue, but you never describe what it is. – David Schwartz Feb 2 '17 at 6:30
  • @DavidSchwartz I feel the title and reference to the other posts would have been enough, but I've edited it in regardless. – NRoach44 Feb 2 '17 at 10:04
  • Still baffled. Do you have any evidence there's an actual problem? Do you suspect there's a problem? Do you just need to cover the light because it bothers you for some reason? Do you just want to know why this happens but there's no problem? Or what? I give up. – David Schwartz Feb 4 '17 at 0:06
-1

Disable defrag

In order to disable defragmentation please try to follow this steps: Logon to Windows 7 computer with any account that has administrative privileges. At the bottom of start menu in search box type DFRGUI command and press enter key. On Disk Defragmenter box click on Configure schedule button and on the opened box uncheck Run on the schedule (recommended)checkbox.

1
  • 1
    You have no evidence to support this is being done by Defrag. – user477799 Mar 28 '17 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.