12

How to permanently disable "Waves' MaxxAudio Pro" / MaxxSense?

Because if you close it (Dell Audio in this case but it may be the same with all Realtek equipped workstations) and reopen it from systray again it will be enabled again. Also if you restart your computer it will be enabled again or if you plug in earphones or something. It's a Windows 10 workstation.

| |
9

My (poor) workaround is to leave it enabled, but disable all the individual components inside a preset called "Off":

Disable all settings

This is not a default preset, just match the settings I have above and then click the Disk/Save icon...it will prompt you to name the new preset. I could not figure out a way to permanently turn it off.

| |
  • Thanks for your answer. As I am not able to give it a try right now.. does it sound (neutral) like if it would be disabled? – Kr15 May 11 '17 at 11:52
  • As best as I can tell, yes. My equip here is probably not good enough to tell the difference. – PatKilg Jun 6 '17 at 15:36
  • How do you access this Dell Audio program in your screen-shot? – PeterX Aug 8 '19 at 23:14
  • @PeterX it´s accessible via clicking it´s icon in systray – Kr15 Aug 22 at 5:23
5

Simply uninstall Waves MaxxAudio Pro.

Start Menu > Waves MaxxAudio Pro > right click > uninstall. Worked for me.

Or, you could change the audio driver from Realtek to Microsoft, which also worked for me, but this seems a bit heavy handed:

Device Manger > Sound, Video, and game controllers > RealTek Audio > Update Driver > Browse my computer for driver software > Let me pick from a list of available drivers on my computer > Uncheck Show compatible hardware > Manufacturer > Microsoft > High Definition Audio Device Version {latest} > OK

 

| |
  • 5
    I tried uninstalling it from the start menu, but it went to the Uninstall or change a program menu, in Control Panel. There was no program by that name in the list. That said, turning everything off still works. – Stackstuck Sep 3 '18 at 20:18
  • 4
    This only works if you go to C:\Program Files (x86)\Realtek\Audio\Waves after installing the Realtek driver provided by Dell. Click on the x64 or x86 version of the program depending on your system. If you use this method Maxx Audio shows up in the "Uninstall a program" list. – Alex Lowe Mar 13 '19 at 15:59
0

I couldn't uninstall the msu I found:

get-package *maxx* | ft -a

Name                                            Version Source ProviderName
----                                            ------- ------ ------------
9PJPPGG8TGVG-WavesAudio.MaxxAudioProforDell2019                msu

But I can uninstall the windows app, and disable an autorun that makes a redundant shortcut in the user profile start menu.

$list = 'WavesAudio.MaxxAudioProforDell2019'
foreach ($app in $list) { 
  Get-AppxPackage $app -AllUsers | Remove-AppxPackage -AllUsers
  dir "C:\Program Files\WindowsApps\$app*"  # verify it's gone
}

# not work, does this install the driver?
#uninstall-package 9PJPPGG8TGVG-WavesAudio.MaxxAudioProforDell2019 -provider msu

# autorun makes extra .lnk shortcut under user profile
# this is like unchecking something in sysinternals autoruns
if (! (test-path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\AutorunsDisabled)) { 
  new-item HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\AutorunsDisabled }
move-itemproperty HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Run HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\AutorunsDisabled WavesSvc
| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.