1
  • Login to Debian server with PuTTY. Right-click on windows, select full screen. Have a nice big working area.

  • Type tmux and immediately the working area is reduced to a standard small terminal window. Tried active key + z, but that (maximizing working area) does not seem to be the purpose of command.

  • Using tmux v1.9 on a Windows machine.

1

Found the underlying problem.

By default on connection the terminal window was sizing to 80x24 (even though it showed text files in wider resolution the typing was limited). Using

stty rows 50 cols 132

resolved this and tmux automatically goes to the specified size.

  • I think it isn't the place where you need to adjusted it, check my updated answer. It should be managed in PuTTY instead of on the server. – Alex Feb 4 '17 at 22:58
1

Run tmux ls, if there more than two sessions than you probably started tmux on the server from console where physical screen is smaller than yours, so tmux will reduce screen to the smallest screen size. Either kill session that was started directly on server or exit from tmux on the server's console.

tmux allowing access to many people to the same users account, so if one working on the server from console, you will see it in your remote ssh sessions, kinda like teamviewer, both can see what are you doing.

P.S.

Another case of this issue could be "incorrect" settings for particular session in PuTTY.

When you opened PuTTY, don't click on a session you want to run, but highlight it and press Load button, then on the left side in "category" treeview expand "Window" branch and change radio button in "When window resized" scope to "Change the number of rows and columns" then go back (highlight "Session" in treeview) to the "Session" and press button Save to save new settings for this particular session. After doing that remote window will automatically resize itself when you resizing or maximized PuTTY window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.