1

So I have an AOC G2460 144hz monitor. I have an Accell DisplayPort cable going from my GPU to the monitor. My settings in the monitor itself, Windows, the NVidia control panel, and the game I'm testing it with are all set to 144hz yet the game looks exactly the same as when I run it on my other 60hz monitor. I don't understand what's going wrong. My GPU is more than capable of running games at above 100fps as I've ran tests before. It's just that the monitor is only displaying at 60hz.

  • 2
    Some games don't go higher than 60, regardless what the settings in the display-config for that game. (Seems to be common bug on systems that have CPU-graphics and a discrete GPU. The game shows the settings for the GPU, but teh game-enigine limits itself when playing to the 60Hz the CPU-graphics are usually limited to.) – Tonny Feb 4 '17 at 15:08
  • Or 30. Frame rate locks suck – Journeyman Geek Feb 4 '17 at 15:10
  • You write the game looks the same. Have you actually verified the resolution and refresh rate in your monitor’s on-screen menu system? Also, do you have both monitors connected at the same time? – Daniel B Feb 4 '17 at 15:10
  • Did you set windows to 144hz? Also my monitor supposedly support 144hz, but I discovered its only through the DVI-D port. hahaha! Is the displayport cable 1.2 or newer? Then you have to go into device manager and verify the monitor name is there and not "Generic Monitor" or similar. – cybernard Feb 4 '17 at 15:36
  • Marketing vs. reality. Marketing will tell you the fastest rate capable, which is really only available under certain circumstances. Marketing will not explain the limitations. – Ron Maupin Feb 4 '17 at 16:11
1

Turns out that some AOC G2460s have defective firmware.

I sent mine off and got a free firmware upgrade and it works now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.