I am using Debian 9, kernel 4.9.0-1 and xfce 4.12.3 and I have a problem that after I lock the screen and close the lid of my laptop and later open the lid I will be prompted with the session login (same login that prompts the first time I boot into the system) and after that with the screen locker. Is there a way to disable this session login and only have screen locker because it is tiresome to type username and password every time I close the lid.

  • In settings manager choose "Session and Startup" and on "general" tab uncheck "Display chooser on login" but it will remove screen locker functionality too. It kinda controversial - remove login protection and keep it in the same time
    – Alex
    Commented Feb 5, 2017 at 11:33
  • It is already unchecked. Commented Feb 5, 2017 at 11:54
  • Check power setting, it is in settings manager/Power Manager there should be settings in action panel for "When laptop lid closed" choose appropriate action you want
    – Alex
    Commented Feb 5, 2017 at 21:39
  • It it set to lock the screen, but the problem is that beside locking the screen I get like logout. I am prompted with username and password to enter instead of xscreensaver window where I need to enter password. After I enter username and password then xscreensaver window shows and I need to enter password once again. I want to bypass entering password two times. Commented Feb 6, 2017 at 16:34
  • Choose "suspend" instead of "lock screen" in power manager
    – Alex
    Commented Feb 6, 2017 at 20:12

2 Answers 2


In settings manager "Session and Startup" choose the "Application Autostart" tab and uncheck "Screen Locker" - keep "Screensaver" checked

Here is the screenshot. Menu > Sessions Startup > Application Autostart



Also check the Xfce Power Manager, on the Security tab, there is a dropdown for 'Automatically lock the screen ' and a checkbox for 'Lock screen when system is going for sleep' as these could also be locking your screen.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .