Here's what I've tried:

  • Updating video drivers: GeForce GT 740M up to date
  • Updating network drivers: Realtek PCIe up to date
  • NEW: Updating chipset drivers: They were already up to date
  • Updating BIOS: Updated to A10
  • Turning off hybrid-sleep
  • turning off hibernation completely
  • Disabling wake timers on all energy plans
  • Turning off waking on magic packet/pattern match
  • Unplugging all USB and Bluetooth devices
  • Setting the sleep idle timer for something else than "never"
  • Disabling waking up devices shown in powercfg -devicequery wake_armed
  • Some other things that I don't remember now. Please ask in the comments before marking as duplicate.

If I turn on my computer and open all my applications, I can put my computer to sleep with no problem, but after some hours of it being on, if I try to put it to sleep, it will turn off the screen, but it will not sleep, and the only way to use the computer again is to force a restart by holding down the power button.

This started to happen after I switched my old HD to an SSD and reinstaled windows 10.

EDIT 1: Tried shutting Chrome off and running powercfg -requestsoverride Driver "Legacy Kernel Caller" System without success


  • When I manually put my machine to sleep, after letting it on after 2+ hours, the screen will turn off, but the power light and the wifi light will stay on, and then I need to forcefully turn the computer off by holding the power button.
  • The powercfg -requests command was showing the following result:

    [PROCESS] \Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\chrome.exe
    WebRTC has active PeerConnections

...But after killing chrome, it started to show the following:

[DRIVER] Chamador Kernel Herdado
(this is equivalent to [DRIVER] Legacy Kernel Caller)

I've tried running without success both:
powercfg -requestsoverride Driver "Legacy Kernel Caller" System
powercfg -requestsoverride Driver "Chamador Kernel Herdado" System

Two important things:
- The Kernel entry vanished after I closed Spotify
- I turned my computer on just now, so I can put it to sleep without problems even with the Kernel entry on my -requests, the issue seems to appear after 2 hours

EDIT 3: I have reasons to believe the Kernel thing is not the issue, this forum post is similar to my problem, my computer won't shut off also, after two hours.

EDIT 4: Maybe this can be related, maybe not...
When sleeping normally (with the computer on for less than 2 hours), the disk light blinks a lot, and then it goes to sleep.
But when the sleep fails, the disk light blinks 3 or 4 times before turning off, and then the wifi light and power light stays on. That's when the computer freezes.
My HD got replaced by a SSD recently, and that's when the problems started. I'm using a Dell Inspiron 14R.

EDIT 5: results from running powercfg -energy:
I've added a plugin to translate the page, you can find it in the first line

EDIT 6: results from running a clean powercfg -energy:
I turned off bluetooth, closed all open programs, killed the audio process and ran the command.
Immediately after that, I tried to put the computer to sleep. Failed again.

  • 1
    What do you get when you run powercfg -requests in an admin command prompt? Feb 28, 2017 at 21:25
  • [PROCESS] \Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\chrome.exe WebRTC has active PeerConnections
    – Lucas
    Feb 28, 2017 at 21:27
  • 1
    So you installed your display drivers and network drivers. What about the chipset drivers, which typically, allow and prevent your machine from entering or existing (S1 through S4) power states. Please update your question, instead of commenting, as the comment section has limited formatting options.
    – Ramhound
    Feb 28, 2017 at 21:28
  • But I already tried letting my computer on for 2 hours without opening any program, it wouldn't sleep even so
    – Lucas
    Feb 28, 2017 at 21:29
  • 2
    You can use powercfg -devicequery wake_armed to identify which devices are configured to wake (or keep the system awake).
    – Ramhound
    Feb 28, 2017 at 21:32

3 Answers 3


Well, after a long time dealing with that problem, I finnaly had some advances. I am not sure what exactly happened, but here are two things I did:

  1. I reset power settings to defaults and changed what I needed from scratch (like, sleep delay etc). Also, I set AHCI Link Power Managment to HIPM+DIPM. I am inclined to believe that this is not important, but I am mentioning this because I did it.
  2. On threads about problems with sleep mode, I have many times seen the advice to rollback or remove Intel Managment Interface Engine driver. I didn't have the option to rollback and removal didn't do anything for me: it was just back after a reboot. So I updated the driver instead. It was not distributed through Microsoft servers for me, so I went for a first link on google and installed it manually. It is now of version for me.

Later, after six hours of runtime, I closed the lid and my laptop went to sleep for the first time since win10 install (except sleep right after restart). I suppose second thing from the list above is what helped. (Of course, I've had hibernation, fast boot etc. disabled a long time ago.)

  • Sorry for taking too long, I had too little time in hands. I reseted my computer and it didn't work, but your second solution did the trick, thanks
    – Lucas
    Jul 10, 2017 at 21:00

I have also had software issues (sleep, dual-boot install failure...) on a dell computer (server) with a newly installed Corsair SSD.

These problems were not present with the original HD. And to this day the same problems persists...

Are you sure your SSD is 100% compatible with the Dell hardware (SATA controller on the motherboard ...). Have you tried contacting Dell about this issue ? Have you tried another SSD/HD ?

As far as I am concerned this is a hardware issue.

Good luck

  • How can I assure that it is in fact a hardware issue?
    – Lucas
    Mar 7, 2017 at 10:10
  • First step IMHO would to try another ssd/hd. I know it is not quite convenient but it would give you valuable info on the nature of the issue.
    – mhham
    Mar 7, 2017 at 10:25
  • I don't have another ssd/hd available, the previous one got damaged...
    – Lucas
    Mar 7, 2017 at 12:14
  • I ran the Dell system diagnostics software and all tests passed, the ssd seems to be working properly. I'll try a clean Windows install...
    – Lucas
    Mar 7, 2017 at 12:17
  • A clean install could be a solution, please keep us posted. In case this doesn't work I also suggest you, since you don't have access to other harddrives, to play with the different BIOS settings related to the hard drive controller (AHCI, RAID, power saving options ...). Also, you should check if the SSD doesn't have a driver that you should install, or even better, one that is officially supported by DELL. Good luck
    – mhham
    Mar 7, 2017 at 12:28

I just had a similar issue, where putting the PC to sleep only turns off the displays.

In my case, there is some software prevent my PC from going to sleep. To solve this, open cmd and type in:

powercfg -requests

Under the System, there is one software process:

enter image description here

You can either close the software or override its power setting:

powercfg -requestsoverride PROCESS “myprocess.exe” SYSTEM

The PROCESS in the command corresponds to the content inside the [] from the command line and SYSTEM corresponds to the category:

enter image description here

  • ok... just realised you have checked powercfg -request... This is not a solution for your problem but this might solve a similar one for others, so I'll keep it.
    – Anthony
    Sep 10, 2019 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .