2

Sometimes, when I press Alt+Tab and then release, the window select menu stays up until I chose a window with mouse or press Enter. Just like if I wouldn't let Alt key go (but I do). Anyone has an idea why this could be the case?

  1. My keybord is brand new (3 days old). Also I opened screen keyboard and see when Alt/Ctrl/Shift/Win keys are pressed and when they are not. So I'm sure none of those 4 keys are sticking by any mechanical reason.

  2. The behavior is "localy stable". I.e. it works many times in a row. And then (when I forget about it) it behaves normaly many times in a row.

  3. I doesn't it when switching from specific windows. But those specific windows are different each time. I mean when it starts to "stick" it sticks all the time for some windows A,B,C and doesn't stick for D,E,F; then it stop to stick and starts again in a while and now it sticks for A,E,F and doesn't stick for B,C,D.

  4. It behaves in the same way with left and right Alt.

  5. I use SharpKeys to remap control keys. Caps -> Left Ctrl, Left Alt -> Left Ctrl, Left Ctrl -> Left Win, Left Win->Right Alt.

  6. I have sticky-keys disabled.

  • 1
    Can you confirm that you have sticky-keys disabled? (Ease of Access Center -> Make the Keyboard Easier To Use) / (windows spotlight search for "sticky keys") – JaredT Feb 7 '17 at 20:40
  • @JaredT, I have it disabled. – klm123 Feb 7 '17 at 20:42
  • 1
    Does the behavior continue if you disable Sharpkeys and reboot? – JaredT Feb 7 '17 at 20:50
  • @JaredT, I think it doesn't! See my answer. But of course, since the behaviour wasn't stable anyway, only time can prove it. – klm123 Feb 8 '17 at 11:48
4

I have discovered that that happended only when a top window is in foreing keyboard layout (I've tried Greek, Russian, German). When I switched layout of the top window to English I could use AltTab normally.

Then I was able to check if this disappears when I turn off SharpKeys (thanks to @JaredT for the hint). And I've found out that the problem was that my Right Alt on my keyboard is actually Alt Gr. So when I used SharpKeys I actually used AltGr+Tab instead of Alt+Tab. Once I've rebinded to use Left Alt instead of Right everything started to work fine.

So I guess AltGr makes Tab to mean something different when you use layout different from English.

| improve this answer | |
  • 1
    AltGr is basically Ctrl+Alt on Windows. For example with Polish layout the normal way to type letter 'ą' is to press AltGr+A and everyone types it like that, but Ctrl+Alt+A works too. Congratulations on figuring it out yourself! – gronostaj Feb 8 '17 at 12:07
2

What you're describing is expected behavior for Ctrl+Alt+Tab.

I use SharpKeys to remap control keys. Caps -> Left Ctrl

After this remapping you have Ctrl directly below Tab. I guess you're accidentally pressing Caps Lock along with Tab.

| improve this answer | |
  • That was my first idea, actually. Now I know about ctrl+alt+tab, and making sure that I press only Alt+Tab. I can make it "stick" 10 times in a row, so I don't think that I can acidentally press 3rd button so regularly, especially doing so consciously. – klm123 Feb 8 '17 at 9:52
  • 1
    I've just discovered that it happends only when top window is in not-English keyboard layout. – klm123 Feb 8 '17 at 11:30
0

Any keyboard input encryption such as Sophos Keyboard Guard in Sophos Home Premium (or Zemana, GuardedID, KeyScrambler or any Anti-keylogger) can cause ALT-TAB delays.

https://support.home.sophos.com/hc/en-us/articles/360021845231-Safe-Online-Banking-Keylogger-protection-feature-compatibility

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.