127

In top menu bar, I accidentally selected to hide that top menu bar ("File", "Help", etc).

As the bar has disappeared, I now cannot access the option to show it again. Not very thought through in my opinion.

image description

How do I show it again? My version is 5.0.4r.

6
  • Which VirtualBox window are you referring to? Which software version are you running?
    – user
    Commented Feb 8, 2017 at 12:29
  • 31
    Try RightCtrl + C
    – jcbermu
    Commented Feb 8, 2017 at 12:32
  • 5
    @jcbermu That hides even the bottom menu. Commented Feb 8, 2017 at 12:35
  • @jcbermu you save my day
    – Dabbbb.
    Commented Apr 20, 2021 at 8:55
  • @jcbermu that will go into Scaled Mode which will generally look worse... Also this will not show the menu again if you had previously explicitly hidden it.
    – red-o-alf
    Commented Mar 19, 2023 at 9:32

6 Answers 6

115

Open virtual machine's settings, then User Interface page. Check this box:

Screenshot of VM settings window on User Interface page, with an arrow pointing to a checkbox on the top toolbar

8
  • 8
    As a side note, if the manager is not open, then the settings can be accessed by the shortcut Host+S, where Host is by default the right control key.
    – NK1406
    Commented Nov 10, 2019 at 20:57
  • 2
    This was not useful for me. I ended up pressing right ctrl + all the letters starting from left to right on the keyboard until I figured out one that changed the display mode. VirtualBox is such a piece of crap.
    – theMayer
    Commented Mar 20, 2020 at 13:11
  • 2
    @theMayer would you be so kind to say which which key?
    – mockingjay
    Commented Apr 6, 2020 at 13:56
  • 2
    I have this box checked on Ubuntu and I still can't see the menu bar. I also can't see the bottom bar, and that is also checked. Commented Jul 11, 2020 at 18:54
  • 3
    I figured it out, if I press Host+C then it shows the menu bars again. Commented Jul 11, 2020 at 19:41
119

You can access the menu while the VM is running by Right Control + Home (by default). It will pop up as a contextual menu through which you will be able to reactivate the display of the menu.

6
  • 4
    This method is definitely the quickest.
    – NK1406
    Commented Nov 10, 2019 at 20:50
  • 2
    for me by default it is not RightCtrl, but RightAlt+Home. Actually in status line it is shown at the very right. Also the modifier key can be set in VirtualBox Preferences / Input / Virtual Machine / Host Key Combination
    – avp
    Commented Jan 18, 2020 at 22:21
  • This worked for me, none of the other methods have. Commented Apr 17, 2020 at 7:05
  • 1
    Thank you, I don't need to waste my screen with menu bar anymore.
    – saeedgnu
    Commented Nov 3, 2020 at 14:24
  • What is the equivalent for MacOS? Commented Oct 13, 2022 at 1:50
20

I had a similar problem where the menus & status bar were gone.

The Host + C fixed the issue. Why?

Looking at the list of hotkeys (From the menu: Input » Keyboard... » Keyboard Settings...), the Host + C is assigned to the Scaled Mode function. The feature that let you change the size of your guest window to whatever dimensions you'd like (it does not even have to be a standard 4:3 or 16:9). This is great, but the side effect is that the VirtualBox system removes the menu & status bar because these may not fit properly when you resize your window in that mode.

So hitting Host + C again fixes the issue because it gets you out of the Scaled Mode. Now they can be sure that the menu & status bar will fit your window as expected.

enter image description here


Note: by default the Host key is the Right Ctrl key. That means if you have the habit of using that Right Ctrl in your day to day usage (like editing a file), you could end up triggering a VirtualBox guest feature without knowing it... some of which could be a shutdown or reboot of the guest!

3

Temporary removing of %USERPROFILE%/.VirtualBox folder with

mv %USERPROFILE%/.VirtualBox %USERPROFILE%/.VirtualBox_old

and starting a virtualbox from scratch allowed to solve the issue with the help of

hotkeys(Host+C & Host+Home, where Host=Right Ctrl)

from this tooltip

2

Step 1: open the Vbox preferences for VMs

enter image description here

Step 2: find the host key. In the example below, it is Ctrl + Alt.

enter image description here

Step 3: find the scale shortcut. In the example below, it is Host + C. Which means Ctrl + Alt + C.

enter image description here

As a result, Ctrl + Alt + C will show the menu, if it had disappeared due to the scale mode.

1
  1. Just move the .VDI file out of the folder made by VirtualBox (otherwise you will delete it by mistake)
  2. Go to the VirtualBox manager program and delete the profile made for the virtual operating system by right click on its icon and selecting delete all
  3. Try to recreate the virtual box but this time use existing .vdi file and the rest just same.
3
  • 1
    Why would I do this instead of re-enabling the toolbar in settings?
    – gronostaj
    Commented Jul 26, 2019 at 7:06
  • 3
    Good last resort if you searched the internet and didn't find an easier solution!
    – saeedgnu
    Commented Nov 3, 2020 at 14:26
  • none of the Host+ worked for me , I had to do this
    – rearThing
    Commented Aug 27, 2022 at 16:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .