2

I have Skype for Business on Windows 7. For a long time I've always been able to click these "Join Skype Meeting" links in e-mails and calendar appointments from co-workers.

Starting last week these quit working for me. No changes have been made to my Skype or Outlook/Office. It keeps directing me to some Microsoft/Skype webpage that wants me to download the meetings plugin. I already had that, but I tried re-installing it several times to no avail.

I can still join meetings if someone directly adds me or if I click the button in "Join Lync Meeting" button in Outlook (which is weird because neither I nor anyone else is still using Lync... we upgraded to Skype for Business a year ago). The "Join Online Meeting" button also does not work.

enter image description here

0

I had a similar problem with a user. What fixed it for us was removing the Skype/Lync add-in (File > Options > Add-Ins > Go) then adding it back in (UCAddin.dll). Once it was added back in and enabled, the Skype/Lync functions worked correctly again. We actually had to remove the add-in and re-add it -- merely disabling and re-enabling it didn't fix the problem.

  • OK I uninstalled it and reinstalled it, but it doesn't seem to work... I'm about to try Microsoft's "Easy Fix" tool on it... – Hack-R Mar 16 '17 at 18:43
  • 1
    @Hack-R So clicking the "Join" link in the email doesn't work, but clicking the "Join" button on the ribbon works? – freginold Mar 16 '17 at 18:55
  • That's how it was before I removed and reinstalled the plug-ins earlier today. Now the ribbon does not work; or rather the extra ribbon button did not come back after I reinstalled. – Hack-R Mar 16 '17 at 21:30
  • Did you check to be sure it's not disabled? (File > Options > Add-Ins, under "Disabled Application Add-Ins") – freginold Mar 17 '17 at 13:28
  • Yes sir. I have to wonder if there's some conflict since my Skype is Skype for Business but my office is still the old Office 2010 because installing 365 didn't work on my computer – Hack-R Mar 17 '17 at 13:39
0

Apparently it has something to do with NPAPI. The quick fix is to change the default browser to IE. There is a longer fix that lets you keep your regular browser. Here is info from MicroSoft on the matter.

https://support.microsoft.com/en-us/help/3057679/lync-or-skype-for-business-client-does-not-start-when-you-click-a-meet

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Donald Duck Jul 5 '17 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.