0

When I try to access my site, I get an empty response (Chrome: 'ERR_EMPTY_RESPONSE', Safari: 'The server unexpectedly closed the connection').

This only happens on one specific machine in one specific wifi. If I change the machine and try within the same wifi, the website loads. If I change the wifi (e.g. mobile hotspot) but keep the machine, the website loads. If I connect over a VPN, it works. I'm guessing it's a DNS issue because it also loads if I enter the IP address correctly (which, by the way, I find out by pinging my website address - which works).

I tried flushing my DNS cache, the router's cache, the browser caches - doesn't work.

What else can I try? I'm stumped.

Edit: It's also notable that I also cannot ssh into the server (it's mine) by the same rules - on any other config it works, but using this specific wifi with this specific computer on the website name doesn't.

  • Verify the DNS configuration is the same for the mobile hotspot and the affected wifi access point for the machine. – Ramhound Feb 8 '17 at 21:52
  • verify you didn't modify your hosts file, it gets resolved even before DNS is put to work. – Hans Propotkin Feb 8 '17 at 22:11
  • My DNS configuration is clear - I tried with both 8.8.8.8 and my router as DNS-Server, neither worked. The hosts file also looks good - it contains just localhost and broadcasthost entries. – Ivorius Feb 9 '17 at 12:52
  • What happens if you run nslookup for that domain on the non-working machine? Does it get you the expected result? Are you the administrator of that network? You could check whenever some special policy for that machine and it's allowed access is defined on the AP/router. – Seth Feb 9 '17 at 13:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.