1

I have a Nvidia GeFroce GT 740M GPU, I installed GPU-Z to monitor my GPU usage. It shows that dedicated memory is not being used at all (0MB usage). But the GPU load is around 50% (in Dota 2). In heavy games like Rust it still does not use the memory of GPU. Please help me fix this. I am running Windows 8.1 x64.

Sensors (running Dota 2 game)

GPU details

  • 1
    Are you sure it has dedicated memory? Most laptop GPUs use shared memory from the RAM. – Waleed Hamra Feb 9 '17 at 9:26
  • yes i'm sure , it has 2gb dedicated memory – Arash Mohammadi Feb 9 '17 at 9:34
  • @WaleedHamra Only integrated GPUs (Intel HD Graphics or AMD Radeon in APUs) use system memory. All discrete GPUs have dedicated memory. – iBug Feb 9 '17 at 10:22
  • @iBug this is not a discrete graphics card, 740m is a laptop gpu integrated. It's up to the manufacturer to decide how memory is handled, and most use shared ram. My 850m uses shared ram. – Waleed Hamra Feb 9 '17 at 10:24
  • @WaleedHamra By 'discrete' I mean that the GPU is not packaged on the same board with CPU. Discrete GPUs are always connected to CPU via PCI-e bus. They always have separate memory called Video Memory (VRAM). Those are often GDDR3 (low-end) or GDDR5 (high-end) while system memory is DDR3 or DDR4, plugged in DIMM slots (SO-DIMM slots for laptops and some ITX MBs). – iBug Feb 9 '17 at 10:29
0

This looks like a GPU-Z Bug, to verifiy this, run Process Explorer or Process Hacker and open the system information window and both tools display here the Memory usage of GPUs:

enter image description here

  • it was a gpu-z bug and process explorer shows the memory usage of the gpu . thanks :) – Arash Mohammadi Feb 16 '17 at 14:35
0

In the first instance i would do a clean install of the latest Nvidia drivers on your machine.

Your system may be using the GPU only for processing and the graphics capability of your CPU if intel I5, 6 or 7 instead. And also ensure that your nvidia card is enabled properly in the bios. There should be a setting to use secondary graphics as the primary card.

I mention this as with a lot of laptops having secondary graphics cards, there are settings in the Bios that govern what the secondary graphics is used for. Hope this helps, cheers.

  • You can also check your memory use of your graphics card by using the nvidia control panel. Right click your desktop, choose nvidia control panel. When it comes up, choose view system topology from workstation in the left hand menu. – twitch.tv Alginnon Feb 9 '17 at 10:11
  • thanks , I have checked bios , it has 2 options for "graphic device" , 1: UMA 2: switchable , I had to choose the 2nd option . I posted some screenshots of the gpuz . My nvidia control panel is so simple , it only has "3D Settings" in the right side , because i am using a laptop and the Intel gpu is taking care of the display and simple stuff. – Arash Mohammadi Feb 9 '17 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.