Didn't explain this very well so I'll try again

Trying a complete new install of Windows 10 on what appeared to be a dying laptop. However, when selecting the partition to install to, it tells me:

"Windows could not format a partition on disk 0. The error occurred while preparing the computer's system volume. Error code: 0x80070057." I'm trying to boot from a USB to install Windows 10.

I've only got Drive 0, which has two partitions. One is 500 MB and says it's 'System', the other is 931 GB and says it's 'Primary'.

Any advice? The laptop is five years old and I'm sure I'll be ordering a new one but I'd like to try and get this working anyway. It's a Dell Insoiron 7720. I've already tried deleting both partitions as suggested on the Microsoft website but the same error comes up.

  • Try formatting in diskpart.
    – vembutech
    Feb 9, 2017 at 13:24
  • The meaning of the message is "The parameter is incorrect", according to PowerShell ([ComponentModel.Win32Exception]0x80070057). Feb 9, 2017 at 13:26
  • As I suggested in your previous copies of this question. Delete the partitions, then install Windows, on the unallocated space
    – Ramhound
    Feb 9, 2017 at 15:12
  • I've tried that mate as I said in the update above. No luck unfortunately.
    – Versace
    Feb 9, 2017 at 15:19

1 Answer 1


It looks as though something is corrupted. If you are able to delete the partitions as described in here and still unable to install onto the unallocated space, it could be that your partition table is what is broken, or your HDD might be failing.

I would say try initializing the HDD and convert it to a GPT partition table. (Personal preference). From the windows install media do the following.

  1. [WinKey] + [F10] (opens the command prompt)
  2. Type "diskpart"
  3. "List Disk"
  4. "Select disk
  5. "attributes disk clear readonly"
  6. "Online disk"
  7. "Convert gpt" Then you may have to reboot and try the install again.

If it still doesn't work I would recommend checking the disk for physical failure in some way (I can't think of what to use at the moment though) or try using a new HDD and see if you can install to it instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.