I have XAMPP installed on my PC, and it works fine. Every service starts fine except Apache. I went to Services in Administrative Tools, and tried to start it from there, without success. I tried XAMPP Shell to run Apache by typing: xampp_cli start apache. That didn't work, either.

I also tried reinstallling XAMPP, turning my computer off/on, restoring the registry from when I first installed XAMPP when Apache worked but still, nothing changed.

Any ideas as to what could be causing this problem?

  • 1
    Have you checked the logs to see what errors (if any) are being generated?
    – ChrisF
    Mar 9, 2010 at 0:15
  • Are you running admin privs? Mar 9, 2010 at 0:17

7 Answers 7


Look in the Apache logs\error_log to see what the problem might be.

The most likely cause is that something else is already listening on port 80.
The error_log should give you a clue, but you can run

netstat -na -p tcp

To see is anything else is using port 80


I had the same problem and solved it by uninstalling other programs like VPNs that I created – TeamViewer etc.

Reason for this problem is a conflict between ports that are specified for programs.


Have you checked any logs to see what the actual error is?

Without more information, it is very hard to help you - however, in my experience, the most common problem for Apache not starting is having another application bound on the same port.

Try changing your Apache settings to use port 81 or anything else and see if that helps. If it doesn't, please say more about your problems or post a log file etc.


I had the same problem. Using netstat -aon showed what PID was listening on port 80. I found the program using Task Manager (turned out to be kservice.exe).

This apparently gets turned by e.g. BC iPlayer, Skype and others. So I switched it off, but to watch iPlayer, use Skype etc I would need it on. So, you'd have to switch on and off and not use both together, I guess.


I had the same issue occur a while back. The system was working fine in a normal working state and one day was unable to automatically launch or activate apache in any way when requested.

My issue was pinned to IIS having re-enabled itself after being disabled (might have been a system's restore, some odd update, or friggin toilet snakes...who knows) but after disabling the IIS service apache was capable of starting normally.

Damn toilet snakes.


I found a comment on Cameron Cooke's blog that suggests changing the IP port that Apache listens on. The default being port 80.

  1. Change it to port 8666 (or anything above 1024)

  2. Locate the httpd.conf file in the following directory:

     [install directory]\xampp\apache\conf
  3. Find the line that says, Listen 80 and change it to Listen 8666. (Or whatever number you did)

  4. Save and Close the file

  5. Restart the Apache service in the Xampp control panel.

There is a caveat they mention:

Now the only catch to this method is that you can't just go to http://localhost/xampp anymore you have to tell your browser which port specifically to use (it will by default use 80), so you will have to use http://localhost:8666/xampp/ (the port is designated by the colon and then the number).

The cool thing is I can run http://localhost:8666 to run Apache and http://localhost:8616 to run my local IIS for .NET projects.


Are you using Skype?

Some Skype versions use port 80, preventing Apache to start. This doesn't seem to be an issue with newer versions, but if you do use Skype, try closing it just to check.

You must log in to answer this question.