1

I have my boot drive encrypted with BitLocker, and have configured it to require a PIN upon boot to continue with the boot process. As my PIN is numeric, I would like to be able to use my keyboard's numpad to enter my PIN.

Unfortunately, it seems Microsoft decided to explicitly disable Num Lock by default in the BitLocker boot environment. I have confirmed this by attempting to toggle Num Lock's default state in my BIOS without any luck.

From Microsoft's FAQ on BitLocker, I would conjecture this is for compatibility reasons (e.g. tenkeyless keyboards, some laptops, etc.), and it seems Microsoft prefers the approach of using the F1-F10 keys instead:

Why do I have to use the function keys to enter the PIN or the 48-character recovery password?

The F1 through F10 keys are universally mapped scancodes available in the pre-operating-system environment on all computers and in all languages. The numeric keys 0 through 9 are not usable in the pre-operating system environment on all keyboards.

I can certainly understand Microsoft's stance on this, but this limitation does not exactly apply to my situation. While there is nothing stopping me from manually enabling Num Lock and proceeding with entering my PIN, it is an inconvenience (albeit a minor one) to remember to do so.

From searching around, I see it can be set once booted to Windows, but I can't find anything relevant to the BitLocker prompt itself. Is there a way to configure this somewhere that I'm missing?

  • Having a small program run automatically when you reach the bitlocker prompt which toggles the numlock state would do it. Perhaps even a small custom driver which does this in kernel space. The major problems with either approach is that you cannot execute unsigned code with secureboot activated until you reach the OS, which is encrypted by bitlocker until you unlock it. From the little I've read here and in the past 10 minutes, it can't be done by software. I could be wrong. – Hydranix Feb 10 '17 at 1:53
  • This will sound ridiculous but maybe a small microcontroller that supports USB could send the numlock key's interrupt transfer request while emulating a generic hid device so it uses the built-in generic driver. – Hydranix Feb 10 '17 at 1:58
0

The default behavior appears to have changed since I originally asked this. I had to decrypt my system for a while to troubleshoot an unrelated issue, and before reencrypting, I've updated to the Creators Update (version 1703) from the Anniversary Update (version 1607). I've observed that Num Lock now appears to be enabled by default. Not quite the answer I was looking for since I'm still unsure of what prompted this subtle change in behavior, but this has nonetheless resolved the spirit of my issue.

0

The creators update changed numlock to be enabled by default. My notebook keyboard has a "simulated numeric keypad" that I personally hate since my passwords are mostly alphabetical (with some symbols), I find this to be very annoying. I hope microsoft adds someway to change this behavoiur at least by editing some registry key or something.

  • 2
    We always appreciate the contributions from our community members, but how does this post differ from the officially accepted answer? – Run5k Apr 19 '17 at 13:01
  • "You must have 50 reputation to comment" – Facundo Sep 25 '17 at 14:13
  • I am aware of the reputation requirement regarding comments. However, that does not mean that you should essentially post a comment as an answer, instead. – Run5k Sep 25 '17 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.