14

Recently I got Dell Inspiron laptop. Every time I plug in my headphones it prompts me with this dialog Which device did you plug in?

enter image description here

Is there a way to disable this prompt? I never get such prompt on other laptops.

Other Info

OS: Windows 10.
Sound driver: Realtek Audio [ 6.0.1.7962 ]
MaxAudioPro

  • 3
    this is no windows dialog, this comes from a (audio) driver software – magicandre1981 Feb 10 '17 at 16:33
  • 1
    It's the Waves Maxx Audio software which generates the pop-up. You can disable it in the preferences or uninstall it (you'll still continue to get sound) – Richard Nov 13 '17 at 20:54
9

To Enable or Disable In Windows 10 on a DELL

  1. Open the program WAVES MaxxAudio Pro
  2. Choose the device, eg. Playback
  3. click Advanced in the bottom center of the window
  4. Toggle the "Show pop-up dialog when device is connected" checkbox

This is what I see (Windows 10 Pro V.1790 [XPS 8920])

  • 1
    I have no "advanced" button. XPS 13 9360 – mm201 Feb 1 '18 at 21:17
  • I have the 'advanced' button, but the dialog does not have the mentioned toggle button. – JaKu Mar 27 '18 at 11:25
  • I added a pic of what I see, for Windows 10 Pro, Dell XPS 8920 – Chad Mar 27 '18 at 12:33
1
  • go to task manager & start-up tab,
    • found WavesMAXX Audio settings, and opened it's properties, to find its full path C:\Windows\System32\DriverStore\FileRepository\wavesapo.inf_amd_whatever is next..
    • opened executable thereMaxx AudioPro and tune-up the settings to pop-up the window on JACK insert.
0

Try this:

  1. Press Windows + R, type control panel and then hit Enter, select Hardware and Sound.
  2. Scroll down and select Realtek HD Audio Manager.
  3. Click the folder icon just above and to the right of where it says analog back panel and just below Device Advanced settings.
  4. Uncheck Enable auto popup dialog when device has been plugged in.
  5. Click OK twice.
  6. Now, restart the computer and check the issue.
  • I dont see any Hardware and sound option in control panel. – Rakesh Juyal Feb 10 '17 at 3:11
  • 1
    Change the View by to Category – Yisroel Tech Feb 10 '17 at 3:27
  • Please change the win+x, as control panel will no longer be available that menu when the creators update is relesed (i'm using Windows 10 Pro Insider Preview, fast build:15031.rs2_release.170204-1546 – DanHolli Feb 10 '17 at 3:34
  • 1
    @YisroelTech, To future proof your answer, I recommend the start-menu search method – DanHolli Feb 10 '17 at 19:51
  • 1
    #4 (Uncheck Enable auto popup) worked for me, though in Realtek HD Audio Manager it was in Device Advanced settings (cogwheel icon) -> Options -> Uncheck Enable auto popup... – Love Aug 3 '18 at 16:44
0
  • Open task manager: right-click on the Windows taskbar > Task Manager.
  • Go to the Start-up tab
  • Disable the following (right-click > Disable):
    • HD Audio Background Process
    • Realtek HD Audio Manager
    • Waves MaxxAudio Service Application
  • Restart your computer

This removed the prompt for me, and I've had no trouble with audio so far.

Not sure what else these do but you can always enable individually if you wish.

(N.B. In older versions of Windows, these start-up options may be in Win+R > msconfig.)

0

If you have an Alienware use Alienware audio advanced then jack info that is actually how I enabled mine works to disable too.

0

They have removed that check box "show popup ..." from the prompt in the latest version. You cannot uninstall as well. But I went to "services", disabled Waves Audio Service and rebooted. No more annoying pop-up when I plug in the headphones. Thank you all for your responses.

This is the hopeless feature that anybody can implement - what an horrible business usecase? who needs this functionality????

  • Welcome to SuperUser! Your post doesn't appear to address the question in a useful manner. Specifically, given the various software versions discussed, you need to specify what system you are on and it would be more helpful to show screenshots of how you got to the "disable" step. You will find that you will have a better experience if you take moment to take the Stack Overflow tour. If you follow the norms of the Stack Overflow community and approach it with an attitude of helping others too, it will serve you well. – Rey Juna Jan 2 at 17:48
  • Or, better yet, take the Super User tour and follow the norms of the Super User community.   :-)  ⁠ – Scott Jan 2 at 18:16
-1

I was receiving a prompt with the same text, but a different appearance. I resolved it by searching the start menu for "Realtek Audio Console", then clicking "Device advanced settings" -> "Enable Jack detection when device is plugged in" -> Off

  • Why the downvote? – cowlinator Oct 31 '18 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.