Recently updated to iMac running Snow Leopard. Connected Canon printers ir7095 and ir5185 via ethernet and downloaded latest drivers from Canon website. Can print to both from InDesign CS3, however, when I select printer features such as heavy paper and printing to stack bypass, it prints but just defaults to plain paper in drawer 1. Also, when printing to ir7095, 0001 prints five times on sheet in background. Is there any way to get the printer features that are available to work?


I've not dealt with those particular imageRunner models, but I've spent a bit of time getting my Canon's to print properly. One things off the top of my head you can try is to check your /var/log/cups/* logs and see if anything odd shows up. On mine there was a permissions problem with one of the files and after fixing it (and removing a section from the PPD) it worked correctly.

A couple other suggestions (a few of them obvious and you probably have already tried them) are:

1) Is the correct PPD selected when you add the printer?

2) Did you set up the printer as an LPD or IPP or other device? Mine will only print as an LPD.

3) Did you set the printer options properly, e.g., sorter and stapler, paper deck, etc.?

4) Have you tried removing and re-adding the printer?

I hope you get it working. From our experience with these machines, our next is likely going to be a different brand. The OS X support is quite wonky.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy