0

I have an email header stored in a .txt file.
An automated process opens the file in Ms Word 2016.

Word gives "Is not a valid single file web page" error.

Obviously word is sniffing the file, it looks like a mime document, word incorrectly decides it's a web archive file, and tried to open it as such.
This fails, as it obviously isn't a web archive file.

Is there any way to switch off this behavior in word?

  • 1
    does it display the same behavior if you open it from within word using the "open" feature? – Blaine Feb 10 '17 at 14:18
  • @Blaine: Yes it does. – Binary Worrier Feb 10 '17 at 14:21
0

Having typed the question I subsequently submitted rephrased web searches, and got Turning off HTML Conversions, give two options.

One can either find the "Confirm File Format Conversion On Open" option in
Options->Advanced->General
and switch it on, this will not work for me, as there's no user to confirm the action, or . . .

... you can remove the HTML file filter used by Word. This is done by running the Word Setup program and then making sure the HTML filter is removed from the system. (You do this by making sure the option is explicitly NOT selected in the Setup program.)

  • 1
    Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Feb 10 '17 at 14:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.