0

I got the following problem:

  • bought a Dell inspiron, it came with a Windows 10 installed

  • formated it and put a Linux Mint

  • It was working just fine

  • suddenly some parts of the keyboard stoped working

  • if I type an l example, a letter ł was printed on the screen, always the same letter for a given key

  • formated it and plugged a USB keyboard, now it was working just fine again

  • in a certain moment, I tested the laptop keyboard and noticed that the problem was still there, even after formating

  • the strangest thing is that after I tested the laptop keyboard, so the USB keyboard also started to display the same problem, exchanging my letters

  • After this, the USB keyboard will only work again if I format the computer. If I boot into a USB Linux I noticed that It is also working there but when restarting, both keyboards not working

So, anyway, I'm not sure if the problem is in hardware itself (because if it was, so the problem continue after formating) or in some type of incompatibility between the device drivers and the hardware because right after installing the OS, the USB keyboard keeps working normally until I type some key in the laptop embedded keyboard.

  • Very quick overview (google for details, tutorials etc.): There are two keyboard translation layers in Linux, one in the kernel (loadkeys/dumpkeys) and one for X (xmodmap). If either thinks your keyboard has a weird layout, e.g. because of a configuration mistake, you can get strange keys. So make sure your keyboard layout is correct. If the layout is correct and just doesn't work as expected, you can fix the layout, key for key if necessary. – dirkt Feb 11 '17 at 17:23
2

Have you checked your desktop's region and language configurations? My guess would be you've chosen another country's settings someplace, and it changes your keyboard layout. Try setting all regional settings to US. Not just language, but region. Some utilities try to be extra "helpful", and overdo it some times.

0

Google Chrome on Windows would automatically change the keyboard setting to Canadian French. So much so I had to learn the hot key sequence to change it back.

The  default being 'Left Alt + Shift'.

There should be an indicator saying which region and language is in use. When the keyboard starts putting out the wrong codes stop and check the settings.

Here's a link to changing keyboard settings for various Linux distros.

[https://www.howtoforge.com/changing-language-and-keyboard-layout-on-various-linux-distributions]

So much for standardisation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.