I've been trying to upgrade my installation of Ubuntu 9.04 to 9.10, but all of the instructions I've found haven't been helping. They mostly say to run the update manager and it'll tell you that there's a new distribution ready. Well, mine doesn't say that.

Things I've run or checked:

  • update-manager -d says:

    Your system is up-to-date
    The package information was last updated less than one hour ago.

  • I've set it to get all new distributions, not just LTS

    $ cat /etc/update-manager/release-upgrades
    # default prompting behavior, valid options:
    #  never  - never prompt for a new distribution version
    #  normal - prompt if a new version of the distribution is available
    #  lts    - prompt only if a LTS version of the distribution is available
  • I'm definitely running 9.04

    $ lsb_release -r
    Distributor ID: Ubuntu
    Description:    Ubuntu 9.04
    Release:        9.04
    Codename:       jaunty
  • Even running the release upgrade from console doesn't help:

    $ sudo do-release-upgrade 
    Checking for a new ubuntu release
    No new release found

This is running from behind a proxy, but I've set it up such that the regular upgrades and apt-get etc doesn't complain. (export http_proxy=http://myuser:mypass@myserver:8080/)

Could you think of anything else which might be stopping me from upgrading?

  • Have you tried recompiling the kernel? – ta.speot.is Mar 19 '10 at 6:34
  • what repositories do you have enabled? if your update manager isn't listing the upgrade to 9.10 it's possible your Apt config isn't pointing to the normal repos. check /etc/apt/sources.list and /etc/apt.d/* – quack quixote Mar 19 '10 at 10:07
  • @quack: i haven't done anything special to my repos: they seem normal to me: deb http://au.archive.ubuntu.com/ubuntu/ jaunty multiverse etc – nickf Mar 22 '10 at 0:16
  • I have the same problem from 12.04 to 14.04: askubuntu.com/questions/449414. – rubo77 Apr 19 '14 at 9:16

I replaced jaunty with karmic in /etc/apt/sources.list, then re-ran apt-get update, apt-get upgrade, apt-get dist-upgrade.

$ sudo vi /etc/apt/source.list

then in vi substitute jaunty for karmic


Save it:


Then run apt-get update:

$ sudo apt-get update

Then run apt-get upgrade:

$ sudo apt-get upgrade

Then run apt-get dist-upgrade:

$ sudo apt-get dist-upgrade

None of the other solutions recommended by anyone else fixed the issue for me. This worked like a charm to force an upgrade from 9.04 to 10.04.

  • or just in one line: sudo sed -i 's/jaunty/karmic/g' /etc/apt/sources.list; sudo aptitude update && sudo aptitude dist-upgrade – rubo77 Apr 19 '14 at 9:17

Maybe the upgrade documentation does help you. There are two other ways on how to do it.

Edit: This guide does also have a new method using the console...if that doesn't work I'm out of ideas, sorry:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
  • The 'Network Upgrade for Ubuntu Servers' section may be especially helpful - try the sudo do-release-upgrade command. – Marek Grzenkowicz Mar 19 '10 at 8:39
  • I tried all those (see the original post): I keep getting "No new release found" – nickf Mar 22 '10 at 0:14
  • Kernel needs recompiling – ta.speot.is Mar 22 '10 at 3:26
  • @taspeotis: I'm not totally sure if you just 'don't know it better' or just try to troll. Recompiling the kernel in Ubuntu won't fix anything, especially since Ubuntu isn't a Source-Distro. – Bobby Mar 22 '10 at 8:17
  • @nickf: Please see my edit. – Bobby Mar 22 '10 at 8:22

Did you already tried to upgrade using a CD/DVD?


Went through the same channels outlined here to try to get it to upgrade. None of them worked.

So I went back to the drawing board.

I had ignored posts that said to just do Alt + F2 (for the Run App window) then type "update-manager -d".

I assumed it was just a keyboard shortcut to Update Manager and I could do that just as easily using System | Administration | Update Manager.

But that -d switch must've made the difference because when I accessed Update Manager through the Run Application window using the -d switch there it was! - the mysterious missing Upgrade to 9.10 prompt.


Change jaunty to karmic in /etc/apt/sources.list.

protected by Community Aug 25 '11 at 1:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.