0

I am having a very strange problem with remote control software. I have a MacbookPro with OSX El Capitan 10.11.6. Initially I connected to this box over wifi using the built-in VNC server, and TightVNC viewer (on Windows 7). All worked well until about a month ago. The initial VNC connection started to take longer and longer to establish, and performance went through the floor... it was taking 30 seconds to repaint. So, I decided to give VineServer a try. Initially it worked great, connecting with TightVNC as before, nice rapid connections and good performance. After a couple days, it too began to slow down, with freezes during logons and the same performance slowdown I had seenn with OSX VNC server (which was turned off). I decided to try one more VNC option... I turned off VineServer and installed RealVNC server and client. The same thing happened... freezes on logon and performance through the floor.

Having had all these problems with every VNC server/client pair I could think of, I turned to NoMachine, which promised to avoid the whole problem by using a different protocol entirely. I installed it, seemed to work fine, but then the same thing happened... freezes during logon, terrible repaint and mouse pointer capture.

What could cause the same problems across four servers and two protocols? It isn't the wifi itself, I have excellent connectivity across that.

2
  • I've had issues like this with bad vidcard driver updates on the target machine. Anyway way you slice it, the problem appears to be with the target system. whats happening on the system while login occurs? any spikes in CPU or massive ram allocation? – Frank Thomas Feb 12 '17 at 7:57
  • CPU usage hovers at about 20%, memory usage is at about 190Mb. – Erik Norvelle Feb 12 '17 at 22:33
0

Whenever odd things like this happen and the computer is physically not at fault, create a new admin user, login as that and then see if the VNC operates more efficiently.

3
  • I would try this, but OSXVNCService loads before any user logins, it runs under a system account, and still gives the same problems. – Erik Norvelle Feb 12 '17 at 22:35
  • Remove the OSXVNC and do a disk utility/repair permissions - Then re-install. – JohnnyVegas Feb 13 '17 at 10:38
  • Make sure screen sharing is turned off under sharing in system preferences. – JohnnyVegas Feb 13 '17 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.