1

I want to use wake on lan (WOL) for a computer (server) in my network from anywhere in the internet. When I (the sender) am inside the home network I simply use wakeonlan with the MAC address of the server's network adapter and send to the broadcast address (255.255.255.255) on Port 9.

From the Internet using the public IP of my home network this does not work. My router allows me to forward specific ports to specific devices however there seems to be no option for port-forwarding to the broadcast address. Is it possible to use WOL without using broadcast? Is there a way to configure my router to forward to broadcast address? My router brand is a Technicolor TG588v which I got from my ISP.

3 Answers 3

1

Just forward to your broadcast address? lets say you have a 192.168.0.1/24 network, then the broadcast address is 192.168.0.255.

Heres a tutorial for your specific router: https://support.zen.co.uk/kb/Knowledgebase/Broadband-Technicolor-TG-582-Configure-Port-Forwarding

Also 255.255.255.255 is the broadcast address of the zero network (0.0.0.0).

From wiki:

A special definition exists for the IP broadcast address 255.255.255.255. It is the broadcast address of the zero network or 0.0.0.0, which in Internet Protocol standards stands for this network, i.e. the local network. Transmission to this address is limited by definition, in that it is never forwarded by the routers connecting the local network to other networks.

2
  • I understand what you are saying but i can't simply type in an IP address where the port should be forwarded to. I can only select devices where I want to forward to but I cant set the address of a device to 192.168.0.255. You can see how this works in my router at the link you provided.
    – VoidStar
    Feb 12, 2017 at 15:47
  • 1
    @Machtl Does the dropdown perhaps offer an option “custom” or anything the like? Otherwise, you could also manipulate the DOM to change to dropdown to a textbox, allowing you to enter anything. With uncertain effects. 😆
    – Daniel B
    Feb 12, 2017 at 16:02
1

What you want won't work because WOL using MAC address to wake up computers that isn't routable over internet and will be dropped at first router.

You have a few options here, you can get a cheap computer such as Raspberry PI that may work 24/7 (and use just a few watts of electricity) in you local network and connect to it from internet over secure SSH channel and send WOL broadcasts from this computer.

Another way is to setup tinc - VPN network in 'switch' mode by using TAP interfaces on both sides.

2
  • 1
    While it’s true that WoL requires only Ethernet, any protocol on top of Ethernet also satisfies that requirement. So sending it via UDP is entirely possible. The “target” MAC address is part of the payload. Whether the packet is distributed locally via L2 broadcast or unicast is irrelevant.
    – Daniel B
    Feb 12, 2017 at 16:00
  • 1
    @DanielB If I didn't misread original question then the question isn't about theoretical case - how to encapsulate wakeonlan's WoL packets over UDP from WAN to LAN, but OP asked about particular modem/router - how to forward from WAN to LAN WoL packets sent by wakeonlan program. AFAIK this particular hardware wouldn't allow to do that.
    – Alex
    Feb 12, 2017 at 21:32
1

What you want to do can be done even without special router support for WoL, and without SSHing or VNCing or otherwise remoting into some box on your home LAN.

However, it requires that your router allow you to set a permanent static ARP mapping for the target device you want to remotely wake. So first you set a port forwarding/mapping for port 9/UDP to the static unicast IP address of the target device, and then you set a static ARP mapping to map that IP address to the target device's MAC address.

Some routers expose this in the web admin UI, some don't. Some let you get to the Unix shell inside the router and do it the traditional command-line way, some don't. Some can have aftermarker Linux distros like OpenWrt, DD-WRT loaded on them (which would allow you to do this), some can't.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.