1

How do I mute the laptop speakers while still getting sound out of my headphones in Windows 7? So even if I pull my headphones out, still no sound comes out of the speakers. As a laptop user, you know that most of the time we work in quite areas such as libraries or night flights. When you accidently pull the headphones jack out, your music blasts causing a lot of unnecessary disturbance.

In Control Panel > Hardware & Sound > Sound, I have only one device: "Speakers/Headphone", so it is unclear how I could disable only the speakers.

  • what sound chip do you have? I'm not sure if its the whole solution but realtek based sound devices have an option for considering the headphones/front panel header and speakers seperate outputs, which might be part of the solution – Journeyman Geek Feb 13 '17 at 10:55
  • As far as I understand, I have Realtek High Definition Audio. – arvidj Feb 13 '17 at 11:46
1

You can't do this unless your speakers and headphones appear as separate devices in the Playback Devices menu, accessible from the audio icon in the system tray. The solution to always make it so one device never plays is to right click and disable it.

enter image description here

If you do not see two separate devices above like this, honestly the easiest thing to do will be to spend $20 on a USB headset. This will appear as a spearate device here and can be independently disabled/enabled from the other devices. Therefore you can make audio only play from that USB headset and never play from the laptop speakers pretty reliably.

  • You do have to enable this feature from realtek's sound manager on many systems, but yeah, this would likely be what OP needs. – Journeyman Geek Feb 13 '17 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.