0

I'm using the latest Windows 10 IoT Inisder Preview (Build 15026) on a DragonBoard 410c and trying to talk to Cortana. I've plugged in a USB microphone that's working fine with the Raspberry Pi (2&3) and which is also being recognized.

However, in the Web portal I see these devices as the default Audio Devices: Speaker: Speakers (QCAUD Real Time (WaveRT) Driver for Qualcomm SoC) Microphone: Internal Microphone (QCAUD Real Time (WaveRT) Driver for Qualcomm SoC)

How can I switch audio devices so the "Hey Cortana" keyword gets recognized?

1

Updated answer I was just informed Cortana is indeed in latest Insider Preview. will follow up after checking into if there's a OS config option for default mic.

In the release notes there are instructions on how to setup and configure the microphone to work. Scroll down to the Cortana Instructions and Known Issues section.

You need to get one microphone and one speaker connected with your device. On the Device Settings page of Windows Device Portal, check if your microphone and speaker is the one displayed against Speakers and Microphone. Click the Refresh button and make sure the correct peripherals are displayed.

Adjust the volume for both to be in the range 40-70%. (Please make sure Microphone is not 0.0)

Please sign in with your MSA credentials when it is prompted. MSA is what you use to sign in to Microsoft services such as Windows, Office, Outlook.com, OneDrive, Skype, Xbox, Cortana and more. An MSA enables Cortana to be a smart and personal assistant, and leverages user information to provide a compelling and useful experience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.