10

I am attempting to use the Convert/Save feature of VLC to convert an mkv file to an mp4. (H.264 video with MPEG-4 AAC audio)

I get the following error:

VLC could not open the mp4a audio encoder

How can I remedy this? VLC 2.2.4 on Windows 10.

Thank you!

4
  • Is there any more information you could provide? Any other debug/error messages? VLC version? Metadata of the video? What media codecs you have installed? What OS are you running this on? If you're running it on a Linux distro, would you be able to provide additional debug info by starting VLC from terminal? Feb 13, 2017 at 20:57
  • I added "VLC 2.2.4 on Windows 10" to my question. I haven't installed any codecs manually.
    – Mooseman
    Feb 14, 2017 at 0:01
  • Would you also be able to add the commands/process you're using to get the error message? Maybe a screenshot? Feb 14, 2017 at 15:28
  • @ServiceManager Open UI -> Convert/Save. No other errors as VLC will continue to convert the video. However no audio track is saved.
    – Mooseman
    Feb 14, 2017 at 19:10

3 Answers 3

25

Go to Tools > Preferences > Input/Codecs > Video codecs > FFmpeg Changing the 'Strict standard compliance to -2 worked for me.

Found this method here: Streaming / Transcoding failed

3
  • 3
    As dankohn noted below, you need to select "Show All at the bottom left" to show FFmpeg option
    – Harry Cho
    Nov 12, 2017 at 8:16
  • My problem was the video that I used VLC to convert, the convered MP4 was no audio, only video, I found that the audio format was not same with the original file format "MPEG-4 AAC" audio.You solution is works for me.
    – Jason
    Jan 28, 2018 at 2:22
  • Like superuser.com/a/1233748/396998 answer says, you need to scroll down to find the Strict standard compliance section (doesn't always show an obvious scrollbar on a mac) - thanks @dankohn!
    – Rock Lee
    Apr 17, 2018 at 6:03
4

On OS X, you select VLC menu and then Preferences. Then click Show All at the bottom left. Then under Video Codecs in the left pane, select FFmpeg, scroll halfway down and change Strict standard compliance to -2.

0

If you want to open an mpeg4 video an alternative is to use the command below:

xdg-open test_video.mp4

If you get error, you might need to install the following in CentOS:

sudo yum install gstreamer gstreamer-ffmpeg gstreamer-plugins-bad gstreamer-plugins-bad-free gstreamer-plugins-bad-nonfree gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugin-crystalhd gstreamer1-plugins-bad-freeworld gstreamer1-plugins-bad-free gstreamer1-plugins-good gstreamer1-libav ffmpeg

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.