1

I have a desktop PC running Windows 7 pro and a laptop running Windows 10 Home. They are both connected to the same 5Ghz wifi network (my home wifi). I shared some folders on my desktop PC because I want to access them from my laptop. Well, the laptop can access them, but if I try to copy them the file transfer speed is incredibly, incredibly slow: 27 minutes to transfer 65 files for a total of 641MBs. I tried with both Windows 10 built-in copy and with Teracopy, and the time was the same. I tried plugging the mains charger in the laptop, and the results were the same, too. This means a file transfer speed from PC to laptop of about 405 KB/sec (KB, not Kb ( = 641 / (27*60) * 1024) !!!

The router is Vodafone's HHG2500 by Huaweii. It is an 802.11ac router; I understand actual speeds are far from theoretical speeds, and that transferring files via wifi is half-duplex, but, still, less than half a MB/sec is unacceptable!!!

Note that both devices are less than two metres away from the router, that the router was not busy doing anything else (no downloads etc), and that there were no other devices connected. I verified with wifi analyzer that there are no other 5Ghz signals that could cause interference. I also tried disabling remote differential compresison on both PCs, but it had no impact.

Is there anything I can do (other than replacing the router) to improve transfer speed? Any software setting I should change?

Note that the desktop PC runs a Plex server, and I can stream HD videos via wifi from that server to my laptop and to an Android tablet just fine. Thanks!

PS To be absolutely crystal clear, both PCs do support 802.11ac

PPS I have tried connecting the PC to the router with an ethernet cable, and I get transfer speeds of 12 MB/sec, which is better but still much much less than what should be achieved with 802.11ac

  • Please edit your Question to include the Wi-Fi specs of your client devices. An AC router can't make older non-AC devices do AC. A 3x3 router can't make 1x1 devices do 3x3, and so on. Calculating expected Wi-Fi speed requires knowing how the capabilities of each client overlaps with the capabilities of the AP (i.e. "router"). – Spiff Feb 13 '17 at 22:07
  • I have added that both PCs do support 802.11ac; by the way, the transfer speed I achieved is considerably inferior to what one could achieve on the old 802.11g – Pythonista anonymous Feb 13 '17 at 22:17
  • Btw, I connected both PCs to an old 300Mbps router I had lying around, and the transfer speeds were about 3.5 MB/sec (about 3 minutes to transfer that folder). I am inclined to think the problem is the router: either there is something wrong in its settings (but what?) or it quite simply sucks! – Pythonista anonymous Feb 13 '17 at 22:23
  • Can you give us your exact WiFi configuration? What channel? What bandwidth? What encryption mode? (For example, 149, 40Mhz, WPA2, AES.) Also, did you change any WiFi settings from their defaults, such as disabling WMM? – David Schwartz Feb 13 '17 at 23:09
  • The channel is chosen automatically by the router but Android shows it as 100. Bandwidth is chosen automatically by the router among 20/40/80Mhz. Encryption is WPA2. The only change I made was to force the 2.4Ghz to broadcast a different SSID, but in these tests I am connected to the 5 ghz one. – Pythonista anonymous Feb 13 '17 at 23:35
3
  • Right click Wifi notification icon.
  • select Network and Sharing Center
  • on the left hand menu choose Change Adapter Settings
  • select your Wifi card, right click select Properties, select the Configure button in the top part of the dialog.
  • go to the advanced tab and there you'll see a list of advanced options.
  • Select "Wireless Mode" and on the right there a drop down menu called Values. Make sure it's set 802.11ac or at least 802.11a and reboot.
  • Do on both PCs, see if it makes a difference.

The default setting in Wireless Mode is to try everything. It may be that for some reason Windows isn't trying to connect in 802.11ac and is defaulting to 802.11n. By forcing it to the ac standard you can check whether the problem is on Windows side or not. Be aware that forcing this setting to 802.11ac will lock you out of older routers that don't support it. If it doesn't help don't leave the setting like this. If it does help, you may have to undo it when you want connect to old routers.

  • Like I wrote, the router is 802.11ac. I have quadruple checked from the router settings and it is set to operate at 802.11ac. Both PCs support 802.11 ac. Also, like I wrote, both PCs are in the same room as the router, less than 2 metres away from the router, with no obstacles walls nor anything in between. For the Americans, 1 metre = 3.2 feet. – Pythonista anonymous Feb 13 '17 at 22:30
  • Sorry, I didn't notice that. What OS do you have, Windows? >Linux? what to do the Wifi settings say? – Boo The Dog Feb 13 '17 at 22:50
  • Windows 7 pro on the desktop Pc and Windows 10 Home on the laptop. I commented above that an old 300Mbps router performs way way better (3.5 MB/sec). What wifi settings, specifically? Are you referring to something in particular? – Pythonista anonymous Feb 13 '17 at 22:54
  • Right click Wifi notification icon, select Network and Sharing Center, onj the left hand menu choose Change Adapter Settings, select your Wifi card, right click select Properties, select the Configure button in the top part of the dialog, go to the advanced tab and there you'll see a list of advanced options. Select "Wireless Mode" and on the right there a drop down menu called Values. Make sure it's set 802.11ac or at least 802.11a and reboot. Do on both PCs, see if it makes a difference. Be aware that forcing this setting will lock you out of older routers that don't do 802.11ac. (continued) – Boo The Dog Feb 13 '17 at 23:23
  • (continued) but at least it will allow you make sure the problem isn't in those setting. You can undo them later if you see they don't help or if you want to connect to an older router. – Boo The Dog Feb 13 '17 at 23:25
1
  1. Make sure you have the router on a clean channel. Note that many "Wi-Fi analyzer" software tools only find interference from other Wi-Fi products, and that may not be the kind of interference you're up against. You need a real 5GHz spectrum analyzer to find non-Wi-Fi 5GHz interference. Note also that 802.11ac typically uses 80MHz-wide channels at this time, so if your AP says it's on channel 36, it's really on channels 36-48, and you need to make sure all of them are clear.
  2. Make sure the RSSI the clients see from the AP (and the RSSI the AP sees from the clients, if it tells you that) is between -40 and -60 dBm. Stronger than -40 dBm could overload the front end of the other devices radios (think about how your eardrums rattle when someone's shouting in your ear, and actually makes it harder to understand what they're saying; a similar thing happens to radios when a nearby signal is far too powerful). If your signal is weaker than about -60 dBm, you won't get your top PHY rates.
  3. Keep wireless QoS (WMM, 802.11e) enabled on your AP and clients. 802.11n and 802.11ac require QoS. Disabling QoS essentially forces standards-compliant devices to fall down to 802.11a/b/g rates.
  4. Don't use WEP or original WPA. Either use no security, or use WPA2 (AES-CCMP) only. WEP and TKIP make use of RC4 crypto engines that weren't fast enough to keep up with 802.11n or 802.11ac data rates, so 802.11n and 802.11ac require WPA2 (AES-CCMP) if you're going to do wireless security. Otherwise, just like the QoS case above, standards-compliant devices have to fall down to 802.11a/b/g rates.
  • Yes to all points except 2, because the desktop pc is so close to the router that the dBm is about -30. However, I tried connecting the dekstop pc to the router with an ethernet cable, and the transfer speed was 12 MB/sec - better but still way below 802.11ac – Pythonista anonymous Feb 13 '17 at 23:42
  • @Pythonistaanonymous Please give more detail on the laptop's Wi-Fi. There are a lot of flavors of AC. 100 megabits/sec (12 MebiBytes/sec) is reasonable for a cheapass 1x1 802.11ac radio that doesn't do 256-QAM. Or for a channel with non-Wi-Fi noise. What are you using for a spectrum analyzer? – Spiff Feb 14 '17 at 0:16
  • I am using wifi analyzer on Android. The laptop is a new Dell XPS 13 with a Killer wifi adapter. I don't think the problem is either of the PC because, as commented above, connecting both Pcs to an old 300Mbps router I get much better transfer speeds (3.5 MB/sec vs 0.5 MB/sec). Also, I achieve 12 MB/sec when one of the PC is wired, which should get rid of the half duplex limitations, ie I'd have expected much higher speeds. – Pythonista anonymous Feb 14 '17 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.