10

Question Status: Unresolved - 7/10/17

My WiFi Adapter, Intel(R) Dual Band Wireless-AC 3165 v19.20.0.6, supports the use of creating hosted networks by "Soft AP," I know so because it has been able to before. But my issue comes that I can no longer able to start the hostednetwork via the usual netsh wlan start hostednetwork

which yields me this error

The hosted network couldn't be started.
The group or resource is not in the correct state to perform the requested operation.

but of course this is due to that

netsh wlan show wirelesscapabilities
...
Soft AP                                     : Not supported

and thus

Hosted network supported  : No

This as I know is a result of a version change in the software and I also have been online seeing that others are having similar issues. Nonetheless, I want to be able to force "Soft AP" to be supported and ultimately force "Hosted Network" to be started, as it is within the capabilities of the wifi adapter.

Note: I would use Windows 10's new built in hotspot creator to do so but you can NOT start it without being connected to the internet, which is my goal. Help would be much appreciated by myself and others with this grief.

EDIT: Registry, Powershell, CMD, Windows Utilities or self-modification of driver files, etc. - are my guesses to what the resolution may look like.

4
  • Was there a recent update for the Wireless Driver? If yes, have You tried a Roll Back for the driver? To your question: it is most likely impossible to force the card to do something it does not know how to do (let's say it's because its driver doesn't support it.) The best you can try is getting back the driver that did support it on this very same card. Feb 14, 2017 at 5:46
  • 1
    @YisroelTech, I am still looking for a resolution to "force" Soft-AP to be enabled with ANY version of the adapters. I already know it is capable as it has worked on previous versions. Do you have any ideas other than just the basic driver works?
    – El8dN8
    Jul 11, 2017 at 22:06
  • There is no such a thing "forcing". The driver is the thing that 'talks' to the actual device to tell him what and how to do it. So if the driver doesn't know how to tell him this then how would he know? Jul 11, 2017 at 23:07
  • @YisroelTech, Linard Arguint below gave a suggestion, which isn't related directly to a driver that could solve the problem that requires programming. Additionally, even though Soft-AP is disabled and HostedNetwork is Disabled, Windows 10 itself can host its own "Hotspot" (although it requires working internet connection). If what you said is true, that the driver must have the capabilities, then how is it possible for Windows Hotpsot to do itself without the drivers supporting it? I want to get a full satisfying answer if there is a way to force it in Windows with this driver. Thank you.
    – El8dN8
    Jul 12, 2017 at 5:30

4 Answers 4

4

https://www.intel.in/content/www/in/en/support/articles/000023257/network-and-i-o/wireless-networking.html The following Intel Wireless Adapters do not support soft AP and ad-hoc features that implement the new Windows 10 WDI model (driver version 18.30 or later):

Intel® Wireless-AC 9560 Intel® Wireless-AC 9462 Intel® Wireless-AC 9461 Intel® Wireless-AC 9260 Intel® Dual Band Wireless-AC 8265 Intel® Dual Band Wireless-AC 3168 Intel® Tri-Band Wireless-AC 18260 Intel® Dual Band Wireless-AC 8260 Intel® Tri-Band Wireless-AC 17265 Intel® Dual Band Wireless-AC 7265 Intel® Dual Band Wireless-N 7265 Intel® Wireless-N 7265 Intel® Dual Band Wireless-AC 3165

HACK PART Install Windows 8 (32/64) drivers for the adaptor. https://downloadcenter.intel.com/download/24863/Intel-PROSet-Wireless-Software-and-Drivers-for-Windows-8-?product=83635

which is 17.16.0 version with Hosted Network Capability (In latter versions ability of hosting network is removed).

Trick Part Open "C:\Windows\Temp" or "C:\Users\User\AppData\Local\Temp" folder. Run the "Wireless_17.16.0_De64.exe" with administrator privilage. Quickly jump to "temp" folder & watch for new temporary folder in which contents of "Wireless_17.16.0_De64.exe" are extracted copy that folder / files to desktop (or a new folder) very quickly as within few seconds extracted temporary folder's content will be auto deleted. Now open device maganer (Windows+R, devmgmt.msc, Enter) Network Adapters >>> Intel(R) Dual Band Wireless-AC 3165 Right click on "Intel(R) Dual Band Wireless-AC 3165" select "Properties" Driver >>> update driver >>> browse my computer for driver software >>> let me pick from available software......>>> Have Disk >>> Browse (Navigate to drivers copied folder & select appropriate driver file) >>> Intel(R) Dual Band Wireless-AC 3165 & Install.

Now with this drivers the adapter will regain the hosted network ability.

Then follow: netsh wlan show drivers

netsh wlan set hostednetwork mode=allow

netsh wlan set hostednetwork mode= disallow

netsh wlan set hostednetwork mode=allow ssid="L460" key="12345678"

netsh wlan set hostednetwork mode=allow ssid="L460" key="12345678" keyUsage=persistent

netsh wlan start hostednetwork

netsh wlan stop hostednetwork

netsh wlan show hostednetwork

netsh wlan show hostednetwork setting=security

commands as per requirement with cmd as administrator.

2
  • 2
    Thank you very much for the thorough investigation and report. Also instead of racing your hard drive for the files, in the temp folder add a Deny Permission for Everyone for Delete rights (two are shown in the advanced permission listing checkmarks). Then once done remove the deny permission.
    – El8dN8
    Mar 25, 2018 at 21:32
  • Thank you for figuring out this solution! This feature was very useful to me, I got used to it being so conveniently present when I needed to write applications that communicate between my phone and my laptop and suddenly being unable to do that wherever there was no Wi-Fi network already available was pretty frustrating, especially as I knew that my wireless card is perfectly capable of it as I have done it several times before. [Luckily when I realized this problem while needing to get something working for an event I was able to temporarily solve it using my phone's hotspot, but still...]
    – Isti115
    Feb 5, 2019 at 18:27
4

Windows has deprecated the old Soft AP and Ad-Hoc Wi-Fi networking options. Wi-Fi drivers have been removing the corresponding features, hence showing the dreaded "Hosted network supported: No" when queried with netsh wlan show drivers.

Instead, Windows now prefers Wi-Fi Direct for these scenarios. Wi-Fi devices and drivers can be checked for Wi-Fi Direct support with the command netsh wlan show wirelesscapabilities. It seems Wi-Fi Direct is normally supported, particularly for the drivers where driver updates have removed the 'Hosted networks" support.

With the Wi-Fi Direct support, Windows implement the new Hotspot features, but gives no easy to to set up a Soft AP for connecting directly via Wi-Fi to the Windows machine (as opposed a HotSpot which connects to the internet through the Windows machine.

However, the operating system support for Wi-Fi Direct and the exposed API still have all the features needed to set up a Soft AP. It's just not exposed as a direct netsh option anymore, which was the case previously. The key phrase to look for is 'Wi-Fi Direct Legacy AP Mode'.

There is a "WiFiDirectLegacyAP" sample on GitHub which does the basics of setting up a SoftAP by assigning the SSID and passphrase, then starting the soft AP. The API goes further, allowing connections to be rejected, and various other options.

I have made a copy of the sample as a new repo and released rebuilt binaries for the sample, to make it a bit easier to just run.

2
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places.
    – DavidPostill
    Oct 2, 2020 at 17:22
  • This does not seem to work, since it sets up a network, but one with no internet options.
    – Obie 2.0
    Oct 14, 2022 at 17:57
1

In case writing your own application is a possibility, have a look at the WiFi Direct API, which offers a legacy mode. Enabling the legacy mode will create a SoftAP with the specified SSID and password. However, specifying no password doesn't seem to be supported.

Have a look at the IoTOnboarding sample to see the legacy mode in action (and to have a better 'documentation' than what Microsoft officially provides): IotOnboarding/IoTOnboardingService/OnboardingAccessPoint.cs

1
  • Sounds like a good idea if I were a C++ programmer (maybe one day I'll take a class), still a good answer for a resolution. But I was thinking of doing it within the vanilla architecture of Windows (10) itself. Do you have any other ideas? (Sorry for not responding so soon, I was just waiting to see more answers; Still am.)
    – El8dN8
    Jul 11, 2017 at 21:57
1

I'd try a different approach. First of all try the following command which looks at the drivers capabilities.

netsh wlan show drivers

Since you mention that your card supports SoftAP, you should be able to see

Hosted network supported: Yes

Then enter the following command to change the Windows WLAN attribute to enable.

netsh wlan set hostednetwork mode=allow

After that you should be able to proceed normally to do what you want.

After Deletion Edit: show drivers and wirelesscapabilities are 2 different commands which show different properties. That is the reason I'm proposing the above solution.

4
  • You are right that these commands are different, but when he writes "and thus Hosted network supported : No" I assume that he means that **Show Drivers" says that. Apr 21, 2017 at 21:38
  • Soft AP is disabled and thus hosted network may not be started.
    – El8dN8
    Apr 30, 2017 at 5:17
  • @user2778427 Did my solution work or presented any different results?
    – Rapsoulis
    May 2, 2017 at 8:43
  • @Rapsoulhs I'm sorry it did not work. My guess to the solution would be more complex, since it goes against the current driver saying that SoftAP is not allowed. However, thank you for your suggestion.
    – El8dN8
    May 4, 2017 at 4:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .