I try to convert some jpgs into one single pdf in using convert.

convert *.jpg new.pdf

But convert does quit after 18 pages. The output then is ok but not complete.

convert-im6.q16: DistributedPixelCache '' @ error/distribute-cache.c/ConnectPixelCacheServer/244.
convert-im6.q16: cache resources exhausted `094708.JPG' @ error/cache.c/OpenPixelCache/3945.

I tried some limit settings but without success. If I try other jpgs then it is the same result.

Any ideas? I have plenty of free memory.

Version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 
Delegates (built-in): bzlib djvu fftw fontconfig freetype jbig jng jp2 jpeg lcms lqr ltdl lzma openexr pangocairo png tiff wmf x xml zlib
  • It looks like a newer version is available so you might just check the site and download and update if applicable. If it's a bug, it may be patched in the newer version. Something to consider perhaps at least. imagemagick.org/script/download.php Feb 14, 2017 at 13:13
  • 2
    Check out the -limit switch.... imagemagick.org/script/command-line-options.php#limit You can likely -limit memory <#> with this switch in case it's your machine running out of memory to process all the files. Otherwise, try to merge less than you are in smaller batches and see if that makes any difference. So if there are a hundred, copy 25 to a test folder and see if the same happens with 25 for example. Perhaps you can merge them all in smaller chunk then at the end merge the PDF documents that were created together. I've always used PDFTK for PDF file merges though. Feb 14, 2017 at 13:20

1 Answer 1


Try to add the following option to increase the cache

convert -limit memory 1GiB -limit disk 1GiB *.jpg new.pdf

If it doesn't work set the limits into the image magic configuration file /etc/ImageMagick-6/policy.xml

<policy domain="resource" name="memory" value="256MiB"/>
<policy domain="resource" name="disk" value="1GiB"/>


<policy domain="resource" name="memory" value="3GB"/>
<policy domain="resource" name="disk" value="2GB"/>

and try it again

  • The change to policy.xml has the same effect as the command line options but is permanent. So it's almost always a good idea, because it's "write and forget".
    – tanius
    Nov 9, 2018 at 22:47
  • 5
    @tanius editing the xml worked, but CLI options didn't. Ubuntu 18.10, ImageMagick 6.9.10-8, with these images: github.com/cirosantilli/media/blob/master/… Dec 23, 2018 at 16:50
  • Same as Ciro reports, cli did not work, xml did. Version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 on Debian 9. May 23, 2019 at 11:49
  • github.com/ImageMagick/ImageMagick/issues/… says that the security policy in the XML will override command line options.
    – jamadagni
    Aug 29, 2019 at 6:58
  • In my case editting polixy.xml helped, my TIFF image contained pages and convert generated like 30 JPG files, this was memory consuming ...
    – Honza P.
    Jun 17, 2020 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .