0

I've just bought Sapphire Nitro RX 470 graphics card (which is PCIe 3). My motherboard is Intel DH61WW (this is PCIe 2). I used to use integrated HD graphics, now I want to use this graphics card. The motherboard has built-in graphics connector of type VGA. My monitor is Asus VX229H, which has 1 VGA and 2 HDMI inputs. The power supply I've bought with the graphics card is Thermaltake TR2 S 500W.

The monitor was connected with VGA port before I buy the graphics card.

Whenever I plug in the graphics card in PCIe slot with proper power (8 pin connector) the fans start to rotate at full speed and the sapphire logo glows. I hope this indicates that it receives proper power.

The problem is the monitor stops receiving VGA signal. When I switch the display mode to HDMI ports (I've tried both ports), the monitor shows no signal. So essentially no input ports of the monitor shows that it receives any signal. If I unplug the graphics card from PCIe port, the monitor starts to get VGA signal again.

Following are the settings for the Video of my motherboard:

enter image description here

Following are the settings under Integrated Graphics Device:

enter image description here

Following are the settings under Primary Video Adaptor:

enter image description here

I'm looking for a combination of settings that enables both the VGA and PCIe graphics, but when PCIe is present, I want the motherboard to use that.

How can I do that?

  • My experience with an MSI motherboard is that the BIOS uses the external graphics card only if internal graphics support is disabled, but this means that the OS will boot with a single graphics card. – AFH Feb 14 '17 at 14:06
  • 1
    some bioses/mobos support what you are trying to do, some don't. Have you ensured the card actually works by itself when you disable integrated? – Blaine Feb 14 '17 at 14:14
  • I'm afraid to disable the integrated graphics, because if my graphic cards is faulty, then I won't be able to use my computer, which I'm trying to avoid today. – Donotalo Feb 14 '17 at 14:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.