2

I followed the instruction that is widely available to enable bash in Windows 10. I updated Windows, turned on Developer mode, enabled "Windows subsystem for Linux (Beta)" in programs settings, and restarted the computer. But when search for "bash" in start menu and click on it, it does something for split of a second and then nothing happens; basically doesn't do anything or open anything. I tried to do it on the system, as well as through remote desktop connection from another machine. Neither worked.

Then I tried to right click on "bash" and run it as administrator (my user is already an admin anyways), but it prompts the following error: "A device attached to the system is not functioning."

I open the cmd and type bash, and I get this error: "Unsupported console settings. In order to use this feature the legacy console must be disabled."

Any help on that?

Thanks!

3
  • open cmd.exe first and next run bash. Now look for any message that show errors. – magicandre1981 Feb 14 '17 at 16:38
  • Thanks magicandre1981!. Here's the error I get: "Unsupported console settings. In order to use this feature the legacy console must be disabled." – Ash3323 Feb 14 '17 at 16:41
  • ok, I posted the steps to disable legacy console. – magicandre1981 Feb 14 '17 at 16:48
1

Open a cmd.exe, do a righclick on the title bar and open the Properties.

enter image description here

Now uncheck the entry Use legacy console (requires relaunch),

enter image description here

close cmd.exe and start a new cmd.exe. Now type bash to start installing of the bash.

14
  • In my case, "use legacy console (requires relaunch)" was already unchecked, so I didn't have to uncheck anything. Nevertheless, I still get the same problem, i.e. when I click on "bash" it does nothing. – user1258252 Jan 4 at 13:20
  • @nbro which win10 version do you use? – magicandre1981 Jan 4 at 13:25
  • Windows 10 pro. I'm not sure if I should follow any instructions here or not: stackoverflow.com/q/44829878/3924118. – user1258252 Jan 4 at 13:30
  • Another weird thing now happened. I enabled "use legacy console (requires relaunch)" , then I restarted the computer. Then unchecked it again. Restarted. Then I opened the cmd and I get a black cmd (i.e. no prompt). I don't know what to do. I checked again that checkbox, then restarted and the cmd now seems to work properly. However, I cannot install bash, I guess, with that checked. So, now, I have one more problem than before. By the way, I had enabled Windows Subsystem For Linux, as explained here: laptopmag.com/articles/use-bash-shell-windows-10. The PowerShell seems to work. – user1258252 Jan 4 at 13:51
  • Pro is the SKU, with version I mean 1909/2004/20H2. – magicandre1981 Jan 4 at 14:01
0

To access bash in the current version of Windows 10 (early 2021) you need to install Ubuntu from the Windows store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.