3

I can install the DocumentDb.Emulator with no errors. However, when I try to launch it I get the following error:

"The program can't start because api-ms-win-core-path-l1-1-0.dll is missing"

I am running Windows 7. Does the emulator require a later version of Windows? I cannot see any system requirements on Microsoft's web site.

5

From DocumentDB Emulator system requirements:

The DocumentDB Emulator has the following hardware and software requirements:

  • Software requirements
    • Windows Server 2012 R2, Windows Server 2016, or Windows 10
  • Minimum Hardware requirements
    • 2 GB RAM
    • 10 GB available hard disk space

So there are probably some missing dependencies.


There is a feedback page that asks for support for previous versions of Windows, stating:

The installer shouldn't run on unsupported platforms. Right now it goes ahead and installs and then the emulator fails with an obscure error about api-ms-win-core-path-l1-1-0.dll

And a reply

Thanks for the feedback and we will consider that. Our backend code uses some crypto APIs that are not available on Windows 7 hence it's not supported currently.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.