22

I have a Dell U2412M Monitor that I connect to my 2015 Macbook Pro with a DVI to Thunderbolt connector.

When I open and view the Terminal on my laptop's screen, the terminal looks like this:

laptop terminal

This is how I want it to look. Specifically, it uses Monaco as the display font. However, when I move the same terminal window over to my external monitor, it looks like this:

external monitor terminal

The font has completely changed.

Why?

3
  • That looks like the original/classic Monaco 12 pt (?) bitmap that the TrueType outline font was based on. It probably has something to do with the fact that the Dell monitor is not a Retina display. Not sure why it isn't anti-aliased though.
    – Spiff
    Commented Feb 15, 2017 at 6:09
  • I suspect Spiff is correct, as the first image has a DPI of 144, while the second is 72. Additionally, they use different ColorSync profiles.
    – MMB
    Commented Feb 16, 2017 at 2:53
  • Any way to achieve the opposite? My terminal opens with the crisp Terminus font on the external screen, but if I drag it to laptop screen and back, the font changes irrevocably to a poor-looking one (not as poor as in your case, though.) Anti-aliasing does change appearance of both, but seems orthogonal.
    – alexei
    Commented Mar 28, 2021 at 2:48

1 Answer 1

34

I solved it this way:

  1. Go to Terminal
  2. Preferences
  3. Profiles (select your profile)
  4. Text
  5. Check Antialias text

Check antialias text option

2
  • 2
    This definitely works (and feels so good) - but why isn't it turned on by default? Is it a performance concern?
    – Aditya M P
    Commented Aug 2, 2018 at 14:27
  • Great answer! Thank you very much!
    – skiabox
    Commented Jul 3, 2020 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .