1

I've recently bought a TP-LINK Archer C2 AC750 (V1) router and I can't setup IPv6. The router is our DHCP server.

I have a DWG874B modem from Thomson and it has IPv6 support. I turned on the v4+v6 mode and I have the v6 addresses listed there.

I tried turning on WAN IPv6, but then it'd automatically fetch my IPv6 prefix as the address, but I think it's not supposed to do that. When I try to configure LAN IPv6, I get lost because I don't know what is Site Prefix, nor RADVD.

If I change the WAN addressing type to SLAAC, the router assigns a v6 address based on the prefix, and it's fine, but I can't get v6 address to be assigned to local network devices.

1

"Site prefix" is simply the network address for your LAN – e.g. in IPv4 you'd usually configure 192.168.1.0/24 as the prefix. The main difference with IPv6, though, is that usually these prefixes are global and obtained from the ISP (often delegated via DHCPv6-PD).

You probably already know the above stuff, but it's worth repeating because it's part of why your setup doesn't work.

(As for "radvd", it's the name of popular SLAAC server software for Linux.)

I tried turning on WAN IPv6, but then it'd automatically fetch my IPv6 prefix as the address, but I think it's not supposed to do that.

No, that's exactly what it's supposed to do. The Archer expects to be talking to your ISP on the WAN side, so it configures its own IP address via SLAAC and tries to obtain a prefix for your LAN using DHCPv6-PD.

But it doesn't have the expected result because you connected the WAN port to another router – the Thomson modem isn't just a transparent modem, it's also a router and it already did the exact same thing as the Archer is trying to do.

In short, you're trying to stack two routers, each having its own LAN – Archer thinks it's talking directly to the ISP, but instead it's talking to the Thomson.

Router stacking is not a big problem in IPv6; it could work if the Thomson was able to provide a prefix to the Archer – but it looks like that doesn't happen. (Maybe the Thomson doesn't have a DHCPv6-PD server at all? Maybe it does, but the prefix it obtained from ISP is too small to sub-delegate any further?)


Your options:

  1. Switch the Thomson to pure bridge mode, so that the Archer could talk directly to the ISP. (Among other things, that means disabling Wi-Fi in Thomson.)

  2. Do the opposite – switch the Archer to pure bridge mode, and let the Thomson serve both IPv4 DHCP and IPv6 SLAAC/DHCPv6. (The Archer can still act as an expensive Wi-Fi access point and/or Ethernet switch; it just won't perform routing.)

  3. If you really want two separate networks, check if the ISP could provide you with a shorter prefix (e.g. a /60 would be enough for 16 subnets).

  4. I don't want to suggest this, and I doubt the Archer is even capable of it, but… if you really want two separate networks but are short on global /64's, it's possible to use a private (ULA) prefix for the 2nd LAN, and have the 2nd router perform IPv6 NAT or NPT.

  • Thank you, posting an answer explaining what I did, but will choose yours as the correct one. An odd thing I noticed is that whenever you change something in the v6 settings, you must reboot the Archer router, otherwise stuff won't work. – Alexandre Feb 15 '17 at 17:45
0

I couldn't find how to setup the Thomson router as a bridge, so I searched and found out that there were 2 ways to set it as a bridge. The first one was to setup Passthrough, but my ISP blocks it, so I had to choose the other option - disable routing.

I disabled routing in the Thomson modem and setup my Archer C2 to clone the modem's MAC Address, but it didn't work. So I just connected my laptop to the modem and it had internet access - I then cloned the laptop's MAC Address on the router and everything worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.