Sorry for the long title. Wanted it be a little specific. I have an issue with my urxvt (rxvt-unicode) terminal emulator that's using a themed fish shell. The problem is that when I launch urxvt with mod+enter the line wrapping messes up causing the datetime part to wrap onto the next line. Furthermore, when i start to type each letter is printed consequently on the next line. see this image.

However, the issue is fixed if i launch the urxvt terminal from the dmenu. image here.

  • Fish version? What does stty -a report in both cases? What does env | grep LINES and env | grep COLUMNS output? – Kurtis Rader Feb 15 '17 at 20:48
  • nvm, I found what the issue was. Thanks anyways :)) – Evgeny Danilenko Feb 15 '17 at 21:05

Hey guys sorry for the hassle, I found what the issue was in this doc. Specifically this part

Gnome-terminal or rxvt-unicode

You need to launch these applications from a UTF-8 locale or they will drop UTF-8 support. Enable the en_US.UTF-8 locale (or your local UTF-8 alternative) per the instructions above and set it as the default locale, then reboot.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.